Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I woke up this morning to my MBP whizzing along (i.e. the fan that is). Looking at Activity Monitor, I saw gpg-agent taking up 97% of cpu, and launchd taking 60%, plus maybe one or two that were also high (one of them was font related -- fontd? I forget).

I am using Mozy, and it was doing a backup over night, but it has been for the last few weeks.

After killing all my apps, these runaway processes remained, so I restarted, and the issue resolved itself.

After restarting, and googling a bit, I checked console, and see hundreds of messages for just gpg-agent, and this is just over the course of a few seconds. I'm guessing this may have been going on for longer since these were the first entries in the log and started at 6am.

9/23/11 6:07:24.504 AM org.gpgtools.macgpg2.gpg-agent: gpg-agent[110]: accept failed: Too many open files

Mozy was my top suspect, but I don't even know if Mozy uses any of those cpu-spending apps I mentioned. Other apps that were running: TimeMachine, Dropbox, Skype, Adium, Chrome, Eclipse, Evernote. Perhaps something with Lion? or KeyVault2 (my disk does have encryption on)?

Other computer weirdness that may or may not be related:

I've had my computer restart on me twice this month overnight (i.e. I go to use the computer in the morning, and it's at the login screen). Sleep should be activating (it is at default MBP settings w/ computer sleep at 12 minutes or so). This may be coinciding with Mozy install, but can't say for sure (Mozy was installed last week, and my first overnight crash might have been before, but I don't recall for sure).

Another issue I've had a few times since installing Lion is I'll go to use the computer after it being in my bag for a few hours, and all the applications are there, but won't respond to my keyboard nor closing. I can interact with the windows (i.e. Cmd-Tab, dragging), but not much else. Sometimes/always the Restart option in the Apple menu doesn't respond, but pushing the power button once does bring up the menu to sleep/restart/shutdown, and I can restart from here. (This issue I reported to Apple as potential Lion bug)

I just remembered, I installed the recommended updates yesterday afternoon (bios update for Lion and Thunderbolt, some security update, and other update for Thunderbolt). It had me restart, then after it seemed to install, brought me to a screen which said, "Hold down the power button until your computer turns off, then turn back on". I assume this was part of the bios update. I think when the computer came back on, it did some installing. Then when OS boots up, OS tells me "it had to restart for unknown reason" and had me send a report to Apple. I sent that along, and continued working on the computer since then (no other restarts). This doesn't seem like it would be related, but figured mention it just in case.

About my system

MBP early 2011 15" base model, Lion built from scratch, KeyVault2 hard drive encryption turned on; SSD and Crucial memory were upgraded after purchase; TRIM turned on via some 3rd party instructions a month or two ago (I can find the how-to article if it seems relevant).

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

My problems covered a few areas, but all stability seems to have been addressed.

Regarding the gpg-agent issue, I haven't seen that come up again, and this maybe attributed to one of two things: 1) uninstalling Mozy; 2) keeping up with the OS X system updates. I don't know which of these for sure, or if the issue is actually fixed, but several months later, I haven't seen this issue reoccur (Mozy was probably uninstalled a week or two after originally posting this).

Regarding the sleeping/freezing oddness, this may have been addressed by OS X system updates as well, or could have been related to this sleep issue I had with locking screen vs. going to sleep, detailed here: How do I stop my MacBook Pro from randomly freezing when trying to go to sleep?

As of this follow-up, I'm running 10.7.4. Hopefully this helps someone else pinpoint a similar issue.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.