Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Whenever I access Terminal and press Command ⌘ + Delete ⌫ my screen flashes white.

It also happens when Chrome's Command ⌘ + F returns no results.

Have I somehow messed up my settings?

I already verified that Universal Access » Hearing » Flash the screen when an alert sound occurs was unchecked. I've tried toggling the setting and still get the flash animation.

share|improve this question
    
Some things you can do to try and isolate the issue is reboot in safe mode (shift key) to test. Also make a new user and log out of the broken user and into the new user to see if it's something local to your account. Good luck hunting this down. If you do - go ahead and answer it with what you found. It might be something unique that we can't reproduce well. –  bmike Sep 21 '11 at 16:02
    
I am having the same problem. I think it's an issue to do with the alert sounds. If you go to the Sound > Sound Effects menu, and click on any of the alert sounds, nothing plays. The Universal Access panel knows that you're not hearing anything so resorts to flashing the screen as an override. I think this is something to do with SoundFlower as I uninstalled that just before this problem began manifesting itself. –  user20095 Mar 14 '12 at 0:11
    
I wanted to enable the screen flashing on bell on this work Mac, but couldn't remember how I've enabled it in the past. So even though this post is asking the opposite question, it still answered mine. Have an upvote! –  Garrett Albright Oct 21 '13 at 21:32

5 Answers 5

You can turn it off in System Preferences > Accessibility > Audio > Flash screen

share|improve this answer

Could have to do with your audio alert set-up. This worked for me in OS X Mavericks. Under apple > preferences > assessability > audio: uncheck "Flash the screen when an alert sound occurs".

share|improve this answer
    
Welcome to Ask Different! This is a duplicate answer but with a different way of accessing the option in a newer version of OS X. To clarify someone else's answer, use the 'edit' or 'improve this answer' button below the post that you wish to edit. –  George Garside Feb 26 at 20:09
rm -f ~/Library/Preferences/com.apple.universalaccess.plist

This will fix it every time. Maybe someday apple will fix the bug that keeps corrupting com.apple.universalaccess.plist.

share|improve this answer
    
OS X 10.8.5 does not have a ~/Library/Preferences/com.apple.universalaccess.plist. Is there an equivalent file of another name? –  Scott Oct 20 '13 at 23:12

This sounds ridiculously simple, but it has worked for me in the past. Try checking and then unchecking Universal Access » Hearing » Flash the screen when an alert sound occurs -- this really sounds like that is the behavior in question, and sometimes setting it and the unsetting it resets to the desired behavior.

This basically checks that the preference file can be written to have a no then a yes and will clear up all sorts of minor issues in how apps can store preferences. The next step is to delete (or move to the desktop) the preference file for the affected application. In this case, the system stores this flash preference here:

~/Library/Preferences/com.apple.universalaccess.plist

At this point, you might need to expand to see if rebooting, trying a new user account helps isolate the issue.

share|improve this answer
    
Restarted. It works now lol. –  carlos Sep 21 '11 at 16:03
3  
@carlos, if the answer helps, please mark it as accepted so others can benefit. –  Dan Sep 22 '11 at 10:14

Restart. This happens to me periodically. Restarting always fixes it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.