Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Whenever I access Terminal and press Command ⌘ + Delete ⌫ my screen flashes white.

It also happens when Chrome's Command ⌘ + F returns no results.

Have I somehow messed up my settings?

I already verified that Universal Access » Hearing » Flash the screen when an alert sound occurs was unchecked. I've tried toggling the setting and still get the flash animation.

share|improve this question
Some things you can do to try and isolate the issue is reboot in safe mode (shift key) to test. Also make a new user and log out of the broken user and into the new user to see if it's something local to your account. Good luck hunting this down. If you do - go ahead and answer it with what you found. It might be something unique that we can't reproduce well. – bmike Sep 21 '11 at 16:02
I am having the same problem. I think it's an issue to do with the alert sounds. If you go to the Sound > Sound Effects menu, and click on any of the alert sounds, nothing plays. The Universal Access panel knows that you're not hearing anything so resorts to flashing the screen as an override. I think this is something to do with SoundFlower as I uninstalled that just before this problem began manifesting itself. – user20095 Mar 14 '12 at 0:11
I wanted to enable the screen flashing on bell on this work Mac, but couldn't remember how I've enabled it in the past. So even though this post is asking the opposite question, it still answered mine. Have an upvote! – Garrett Albright Oct 21 '13 at 21:32

This sounds ridiculously simple, but it has worked for me in the past. Try checking and then unchecking Universal Access » Hearing » Flash the screen when an alert sound occurs -- this really sounds like that is the behavior in question, and sometimes setting it and the unsetting it resets to the desired behavior.

This basically checks that the preference file can be written to have a no then a yes and will clear up all sorts of minor issues in how apps can store preferences. The next step is to delete (or move to the desktop) the preference file for the affected application. In this case, the system stores this flash preference here:


At this point, you might need to expand to see if rebooting, trying a new user account helps isolate the issue.

share|improve this answer
Restarted. It works now lol. – carlos Sep 21 '11 at 16:03
@carlos, if the answer helps, please mark it as accepted so others can benefit. – Dan Sep 22 '11 at 10:14

As discovered by corwin.amber in another post, the problem sometimes lies with a dead coreaudiod and can be fixed with:

sudo killall coreaudiod
share|improve this answer
I can note that this seems more frequent if you use external audio. I personally use the DisplayPort for my audio out to a sound system hooked up through my monitor, and have seen this issue. – jidar Nov 24 '15 at 2:25

Restart. This happens to me periodically. Restarting always fixes it.

share|improve this answer
Unfortunately, that seems to be the only thing that fixes it for me too. – Julian Jul 11 '15 at 18:22
rm -f ~/Library/Preferences/

This will fix it every time. Maybe someday apple will fix the bug that keeps corrupting

share|improve this answer
OS X 10.8.5 does not have a ~/Library/Preferences/ Is there an equivalent file of another name? – Scott Oct 20 '13 at 23:12
@Scott I am on 10.8.5 and I have it – user193130 Oct 1 '14 at 23:12
Does not work for me, 10.10.5 (14F27) – Ian Vaughan Aug 28 '15 at 9:58
Worked for me on 10.10.4 – TiMESPLiNTER Sep 17 '15 at 13:22

Uncheck the 'visual bell' box in the preferences for your terminal style.


Bell: Audible bell Visual bell <>

share|improve this answer

Could have to do with your audio alert set-up. This worked for me in OS X Mavericks. Under apple > preferences > assessability > audio: uncheck "Flash the screen when an alert sound occurs".

share|improve this answer
Welcome to Ask Different! This is a duplicate answer but with a different way of accessing the option in a newer version of OS X. To clarify someone else's answer, use the 'edit' or 'improve this answer' button below the post that you wish to edit. – grgarside Feb 26 '14 at 20:09

Reposting here from another post as suggested by David Wolever.

In a similar situation, I was about to give up and reboot, but then I found that restarting the audio daemon resolves the issue:

sudo killall coreaudiod

The symptom was: in the "Sound Effects" system setting panel, selecting alert sounds didn't do anything (usually it triggers a preview of the selected effect). My guess is that OS X fails to play an alert sound, and falls back to the visual cue.

share|improve this answer

You can turn it off in System Preferences > Accessibility > Audio > Flash screen

share|improve this answer

Checking and then unchecking Universal Access » Hearing » Flash the screen when an alert sound occurs works pretty well. Seems there is some bug. Apple need to solve this issue.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.