Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Happens intermittently: When I unplug my Sony headphones, I am unable to get my 17" MBP (2.8ghz intel core 2 duo, running Lion), to make any sound. I've tried a handful of different hardware, and nothing will make a peep.

Restarting "fixes" it.

share|improve this question
Have you tried simply reinserting the headphones and pulling them back out again? Sometimes pulling headphones out too quickly can leave the OS confused. – Samuel Mikel Bowles Sep 20 '11 at 1:38

Its a bug Lion has.

This thread should provide you with more info of users suffering the same bug.

This app claims to fix it (I found it on that same thread).

I haven't had the bug for a while, but I did have it quite a bit before. I really hope Apple fixes it, by 10.7.2 perhaps.

Hope it helps!

Edit: Probably the most relevant information in the thread is that it seems to be a bug on Core Audio. $ sudo killall coreaudiod quits the process and the system automatically restarts it, effectively providing a quick fix to the bug. The rest are people posting about their personal experiences and thanking the developer of the app that automatically applies this fix.

share|improve this answer
Please add the relevant content to your answer; if those links die, your answer becomes useless. It's also worth noting it happens to me on 10.10 with a Late 2013 MBPr 15-inch. – George Stocker Oct 30 '14 at 13:54

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.