Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Is it possible to have Aperture import videos alongside pictures when importing from a phone. It can handle videos, but when it shows me the list of things to import, only pictures are displayed.

share|improve this question
add comment

2 Answers

Aperture 3.2.2 imports video and stills by default for me from my iPhone with iOS 5.0.1. Are you perhaps using older software or different hardware?

The only time I've seen Aperture not show items for import is when you take more photos / videos after the import window is open and the new captures will not show until you disconnect and reconnect the USB 30 pin connector.

share|improve this answer
    
As far as I know I'm using the latest version (at least, I never skipped any updates, but I'm going to check when I get home), but I'm not using an iPhone, I'm using an HTC Desire. –  J. Pablo Fernández Jan 3 '12 at 16:24
add comment

You may have video files disabled in the import options.

  • Open Aperture and click Import
  • Click Import Settings on the right, and make sure File Types is checked in the list to show the File Types options.
  • Under the File Types options, make sure Exclude videos is not checked.

If these options are set properly, connect the phone, locate the video files in the Finder, and verify they're playable by Quicktime player and/or the Finder (via Quick Look). You can also try importing the file directly, by dragging it onto Aperture's dock icon.

If you can't view the video via Quicktime Player or Quick Look, try installing Perian and rebooting, but I'd be surprised if this is the case; most Android phones record in standard formats.

Update: Missing Sync reportedly correctly synchronizes Android videos, according to someone with the same phone as you http://androidforums.com/htc-desire/79684-htc-desire-mac.html

This is more of an alternative, but hope it helps.

share|improve this answer
    
Thanks for the information. The settings were correct, videos are not being excluded. They are playable and I actually import them like you said, but since it's a manual separate process I tend to forget and it gets messy. –  J. Pablo Fernández Jan 10 '12 at 10:15
    
I updated my answer with a link to a report that Missing Sync does what you want. Can you confirm? –  BeeDee Jan 10 '12 at 17:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.