Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Every time I go to jailbreakme.com on my device, the site says "Not supported on your device."

Like I said, I have an iPod Touch 4g, ios 4.3.3. And the site clearly says my version and device is supported. Help please, thank you.

share|improve this question

migrated from superuser.com Sep 17 '11 at 6:41

This question came from our site for computer enthusiasts and power users.

    
I found the answer. I was using a different browser than Safari. :) –  d4ryl3 Sep 17 '11 at 6:54
2  
Post it as a real answer using the "Answer your Question" button below! –  slhck Sep 17 '11 at 7:55
add comment

2 Answers 2

Try going to Settings>General>International and choose region format "Hawaii United States". Then open www.jailbreakme.com again from Safari.

share|improve this answer
add comment
up vote 1 down vote accepted

I found the answer: I was not using Safari.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.