Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Running Lion with Windows 7 boot camped, I modified my Mac OS X partition and reduced its size by 100 GB. I formatted the new 100Gb to FAT 32.

When I restarted my computer, I received the "No bootable device -- insert boot disk and press any key" error. I restarted and logged into Lion and the Startup Disk utility still recognized the boot camp install but I still couldn't restart into Windows. I was still able to see the content of the files in the Boot Camp partition via Finder. I tried running from Windows 7 DVD and repairing, but Windows repair didn't recognize any installs.

In the Disk Utility, I deleted the new partition I created (100gb). After deleting it, I noticed the boot camp partition's name changed to disk0s4 and was marked as FAT 32 format. Now I can't look at the boot camp files in finder and startup disk utility isn't recognizing the boot camp partition.

How can I fix the boot camp boot loader, or ay least access my files from lion?

Update: The default boot is going to the Windows partition but it shows the "No bootable device -- insert boot disk and press any key" error. I assume that means the partition is still good?

Update 2: I ran Windows 7 install via a DVD and got to the point where it shows you a list of drives/partitions available. It showed me the boot camp partition (I recognized it by the partition size, although it was about 15 GB short of what I expected) as being "RAW" format with all space being empty. sad face

share|improve this question

3 Answers 3

Don't change any partitions after instaling Windows 7 Bootcamp, otherwise Windows 7 won't work.

share|improve this answer
    
So in other words, if the partition sizes you choose initially are not optimal, you need to redo the entire boot camp install? –  Jordan Sep 9 at 3:00
up vote 0 down vote accepted

As I suspected, the files were still fine but some bad things happened to the boot sectors.

I ended up running TestDisk to copy all the files to an external hard drive, but it wasn't able to fix the boot sectors.

share|improve this answer

I have experienced the same problem too, and found this thread in search for an answer.

Now I finally I know why - my internal dvd but it is not longer working and I use the external or usb bootable windows 7.

I didn't use the internal dvd for some time and missed the fact that this won't work with out original iMac's dvd being operational.

I recommend you test and get your DVD hardware fixed.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.