Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Every time I listen to music on iTunes or VLC, I notice that the process coreaudiod causes an unusually high CPU usage (5% or more).

Are you having the same issue? What's the reason for such a high CPU usage?

  • Recent OS X updates have not changed this observation. Restarting (or killing the process so it respawns) doesn't fix the problem. After a couple of seconds, CPU usage of coreaudiod goes above 5% again.

  • It's important to note that using line out makes the problem go away and coreaudiod's CPU usage goes down to 1%-2%.

enter image description here

share|improve this question
1  
yeah, i read those, none of the fixes fixed the issue... –  Haytham Elkhoja Sep 13 '11 at 16:19
1  
Yes, how weird is that? –  Haytham Elkhoja Sep 15 '11 at 5:49
1  
I'm having the same issue. Mac OS X 10.7.2; coreaudiod is using 8% CPU constantly. Issue goes away when I plug in the headphones. 2.4GHz Core 2 Duo MBP. I've read somewhere that Parallels could be under suspicion - anybody here using Parallels? –  Scott Lowe Oct 30 '11 at 18:46
1  
I experience the same too when I play through the speakers, I'll try the headphones. Thanks for sharing the tip, Haytham. –  Global nomad Nov 20 '11 at 9:13
1  
This problem still persists in 10.7.3. When listening to the radio, the coreaudiod is up at 10%! –  gentmatt Feb 18 '12 at 9:00

9 Answers 9

This appears to be a know issue, and hopefully will be fixed in an update in the future. For now though, there are one or two things you could try (it goes without saying that make sure all software is updated to its highest stable version)

  • First of all, restart your computer.
  • Second of all, install Onyx. Install and open, and click on the 'Cleaning' tab. Under that, make sure, on the 'System' section, that the 'Audio Components' option is checked. Click execute, and let it do it's thing.
  • Then open Disk Utility, select your startup volume, and repair all disk permissions. Let it run, then close all apps and restart again.

I hope this helps relieve the problem in some way, but I cannot guarantee it, having not been afflicted with it myself, however this is the course of action I take whenever my CPU usage is higher than I would expect it to be due to a process.

share|improve this answer
1  
This is not a solution in any way, shape or form. –  Haytham Elkhoja Dec 28 '11 at 11:24
2  
CPU went from 8 to 120 % and was constantly fluctuating. Deleting Library/Preferences/Audio did not work for me but the instructions from All Maxwell did the trick. –  Yves_T Apr 11 '13 at 16:51

Seems like creating the folder Library/Preferences/Audio worked for at least some people. Have you tried it?

share|improve this answer
    
The user just copied /Library/Preferences/Audio/ from another computer. I also had the issue on my previous Mac though. If it worked for someone, can you upload the plist files somewhere? –  ؘؘؘؘ Dec 31 '12 at 10:18

This could be audio plugins that run under core audio.

share|improve this answer
    
While this seems reasonable at first, it does not explain why "plugging in earphones or external speakers makes the problem go away". –  gentmatt Jan 24 '13 at 12:37

I just had the same issue on 10.8.4.

Quitting Boom.app seems to have resolved it for me.

I think Boom uses similar technology as AirFoil, so it might be worth quitting or uninstalling anything that somehow captures and modifies or redirects the audio-stream.

Perhaps the app afflicting you saves state per output device, and it's state for your built-in speakers is borked somehow.

share|improve this answer
    
The poster did not indicate that he's using any third-party plugins or applications, other than VLC. –  tubedogg Sep 3 '13 at 21:13
    
I tried muting BoomDevice (under System Preferences->Sound) in both the Output and Input device lists, and my CPU usage for coreaudiod immediately dropped. –  Sean the Bean Mar 19 at 19:49
    
Interestingly, I uninstalled Boom a long time ago, but BoomDevice is still installed.. I'll have to fix that. –  Sean the Bean Mar 19 at 19:50

The high CPU usage of coreaudiod is due to the ambient noise reduction software working (surprisingly, even when the built-in microphone is not in use).

Go to System Preferences -> Audio and uncheck the noise reduction box, and you should see coreaudiod CPU usage drop to 1% or less.

share|improve this answer

I found that killing Flash fixed the problem for me.

I rebooted yesterday to see if that would fix the problem, but by this afternoon, coreaudiod had accumulated 6 hours of CPU time. I have not used any audio apps (VLC, iTunes, etc.).

I turned off "ambient noise reduction" and there was no impact - still at 8-10% CPU. I noticed Flash running with a much lower CPU (~1%), but I did not realize that I was visiting any Flash-based websites. I killed Flash, and coreaudiod disappeared from Activity Monitor. When I re-enabled "ambient noise reduction" there was no impact - coreaudiod still gone. (This all on OS X 10.9.)

share|improve this answer

Disabling "Google Voice Search Hotword (Beta)" extension in Google Chrome helped... OS X 10.9.1 Mavericks

share|improve this answer

My coreaudiod was using about 12% before unchecking the ambient noise reduction option. At that point it dropped to 5%. So, that helps but I'd like to see it closer to 0%.

share|improve this answer

Some people claim this helps:

$ sudo launchctl unload /system/library/launchdaemons/com.apple.audio.coreaudiod.plist
$ sudo rm -r /Library/Preferences/Audio/
$ sudo mkdir /Library/Preferences/Audio
$ sudo chown -R _coreaudiod:admin /Library/Preferences/Audio
$ sudo launchctl load /system/library/launchdaemons/com.apple.audio.coreaudiod.plist

For me it turned out the cause was this HipChat issue.

share|improve this answer
    
Turns out it was HipChat for me too –  Daniel Beardsley Nov 6 at 20:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.