Sign up ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Is it possible to disable trackpad when running Windows 7 on Macbook Air/Pro? Anyone with this setup can confirm that it's possible?

(I don't use this setup yet, I'm just thinking about it, and want to make sure it supports my needs).

share|improve this question

5 Answers 5

up vote 2 down vote accepted

You can disable it in System -> Hardware as far as I remember.

share|improve this answer
I was looking for simple checkbox rather than disabling device in hardware list, but that will also work I guess. Thanks. –  Peter Štibraný Sep 9 '11 at 18:00
Well there's also the Touchpad settings in Control Panel -> Mouse but I'm not sure if you can perma-disable it there. Might be worth a look. –  Nicholas Smith Sep 12 '11 at 8:18
that's why I asked here ;-) I don't use this setup yet, so I cannot look myself. Thanks for your help. –  Peter Štibraný Sep 12 '11 at 10:02
I'm too much of an Apple nerd to remember the Windows control panels with anything other than abject horror ;) –  Nicholas Smith Sep 12 '11 at 10:06

Via Control Panel you can't. Although you can disable the "touch click", and that way the click is made by "clicking" the trackpad, thus reducing accidental clicking. There are 3rd-party tools for disabling it easily, or when a mouse is connected, but the few I tried (Trackpad++ and TrackpadMagic) didn't work for me (MBA Mid2011 + Win7)

share|improve this answer
How do I disable "touch click"? That's the stuff that makes the cursor jump while I'm typing. And I hate hate hate it. Actually I just found this Touchpad++ driver. Gonna try it next: –  user16276 Jan 10 '12 at 18:22

Start > Control Panel > Devices and Printers > Apple Keyboard/Trackpad > Right click, Properties > Hardware > HID- Compliant mouse, MICE and OT.. > Properties > Anable/Disable//

You must disable the both Mice and ot.. becouse one is for the click's and one is for the mouse movement.

Greetings, Georgi.

DisableTrackpad DisableTrackpad DisableTrackpad

share|improve this answer

Well, good news. I figured out how to stop that annoying errant cursor from suddenly moving my typing to an unintended place.

Ignore all you have read above.

On the Start bar at the bottom on your screen, far right find the Boot Camp icon. Click it See "Boot Camp Control Panel..." Click it Click Yes to allowing to proceed See at the top tabs "Trackpad" Click it unclick Tap To Click click OK


Now touching the track pad won't move the cursor...only pressing down to "click" it will.

share|improve this answer

You can disable it in bootcamp control panel.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.