Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I dual boot Windows 7 and MacOS X on my iMac.

Recently I needed to type some text in a non-English keyboard layout in Windows. I installed the second keyboard layout the way I usually do, but when I pressed Alt-Shift to switch, nothing happened. After playing around with the settings a bit more, I was able to switch to the other keyboard layout, but not back to the regular American English layout. No language bar either.

alt+shift does not work, nor does Ctrl+shift, nor does specifying a separate key combination for each layout like Ctrl+0 | Ctrl+1 | Ctrl+shift+0

Interestingly, the Text Services and Input Languages dialog box dies with I select the United States (Apple) layout and click on Properties.

I am running W7 64-bit on an 20" early 2009 iMac. I have the version of the wired, USB Mac keyboard without the keypad and the middle group of keys. Bootcamp is up to date.

Update

I did a bit more troubleshooting and discovered that for some reason, ctfmon.exe, which I believe is the process that handles switching between keyboard layouts and displaying the language bar, isn't running. I also encountered several other posts on the Net with people complaining of similar issues when running Windows under Bootcamp, but unfortunately no solution.

Anyway, trying to run ctfmon.exe manually (from the start menu or Run dialog) or adding it to the Run section in the registry does not fix the isssue because ctfmon.exe simply refuses to run.

share|improve this question
    
Is that a bluetooth keyboard? Do you have a normal USB keyboard that we can test with? –  TheWellington Sep 12 '11 at 20:55
    
I neglected to specify that what I'm using IS a wired USB keyboard. The question has been edited to stress this. –  dandan78 Sep 13 '11 at 8:53
    
Can you still change the keyboard layouts using the mouse by clicking on the keyboard icon in the System Tray in the lower-right corner of the Windows desktop? (you have to enable this in the Control Panel settings) –  Wheat Williams Sep 13 '11 at 15:41

2 Answers 2

up vote 3 down vote accepted

I had this problem and fixed it by: Control Panel -> Regional Settings -> Keyboard and Languages (tab) -> Change keyboards (button) -> Selelct the top language added: (English United States) -> then click "Add" -> Navigate between the options to (English United States) -> click on "keyboard" -> now check the option "US"

This solved my problem, I hope it solves yours

share|improve this answer
    
Yup, that was it. Haven't needed to boot into Windows for ages so I completely forgot about this problem. Thanks. –  dandan78 Apr 3 '12 at 8:35
    
Sadly, I cannot double-upvote you :) I had this problem for an year now and just got used to just using the US keyboard, but today I finally found your post and it solved the problem. Seems the problem is with Apple's keyboard layouts. They are somehow breaking the CTFmon, which is responsible for the language bar. –  bisko Apr 28 '12 at 17:16

I'm to some extend sure that this is a problem with the Apple English Keyboard dll. Here is why I think so. Go to "Text services and input languages". If "United States (Apple)" is among the input languages, try to double click it. If it crashes the dll host then you have the same problem as me which I think has something to do with bootcamp drivers.

I tried to solve this by remove the afformentioned keyboard layout and add another English keyboard. Now the language bar is visible.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.