Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

So I'm not at all impressed with the "Continuous" view in Preview, that seems to be the default way PDFs are opened. Is there a way to change the Preview.app preferences in such a way as to set "Single Page" as the default?

share|improve this question
    
possible duplicate of Changing Preview.app's default View state in Lion –  Mark Aug 12 '12 at 20:33

2 Answers 2

In Mountain Lion, at least, there's a Opening for the first time entry in the PDF pane in Preferences, where you can select Single Page. This sets the default view mode for all PDF files.

If you for some reason can't get it to work, you could try this Terminal command (don't know if it will work in Lion) and restart Preview:

defaults write -app preview kPVPDFDefaultPageViewModeOption -int 1

(in ML, the value of kPVPDFDefaultPageViewModeOption changes to 1 in Preview's plist, when selecting Single Page)

share|improve this answer
1  
Unfortunately this does not seem to work in Lion (however it does give me a reason to upgrade to ML) –  Mark Aug 3 '12 at 14:14
    
OK... (did you try the terminal command, btw?) –  user26667 Aug 3 '12 at 14:19
    
yes I did try it –  Mark Aug 3 '12 at 14:22

This terminal command should solve it

defaults write com.apple.Preview PVPDFDisplayMode 1

PS. This won't work in ML only in Lion. And you may have to restart before it will become functional.

share|improve this answer
    
and now after reboot it does not work. The default is there –  Mark Aug 12 '12 at 20:29
    
Thats very strange... Have you tried doing it again and rebooting again to see if the same thing happens. If so I'd suggest you may have some corrupt library file that stores the setting. I had a similar problem where my trackpad settings would reset whenever I rebooted and the only way to solve it was to clean install OSX so that all of the library files were replaced. –  InfluenceJamie Aug 12 '12 at 22:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.