Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I am having issue when connecting to my school's unix remotely via Terminal (SSH) and attempting to edit code in emacs on my Mac. I have a Macbook Pro running Mac OS 10.6.

I use the emacs that is installed on their Unix operating system (not emacs installed locally on my Mac). I made sure that Terminal is running vt100 emulation, as that is the setting that I was told to run it at.

Everything works fine except for some keyboard behavior issues. When I attempt to save in emacs (Ctrl-x Ctrl-s), it doesn't seem to accept it and and makes the "bump" error noise, as in bad input. However, when I attempt to do this on another Mac (with a full keyboard), the save command works fine. It also works fine when I am running a virtual installation of Ubuntu on my Mac laptop. And when I use a Windows machine, running PuTTY, the save command works fine. So I am thinking it has something to do with my Mac's keyboard (since it is a laptop keyboard, and not the full keyboard)? Or is there a setting that may be wrong?

Any help would be greatly appreciated.

share|improve this question
    
What does M-x describe-key show? –  Mark Sep 6 '11 at 15:57
    
@Bret Moore - what are the differences between the two Macs and their Terminal configs? As a side note, have you tried using iTerm2.app instead (it's a general improvement over Terminal.app and worth using anyway.) –  Slomojo Sep 7 '11 at 0:41
    
The M-x describe-key doesn't show anything because the command is not being completed. I am able to successfully complete the Ctrl-x s command, but not Ctrl-x Ctrl-s. It just makes an error noise when I try to finish with a Ctrl-s. @slomojo: The differences, as far as I know, are none between the iMac that I have tried before and my laptop. We use the same emulation, etc. I did try iTerm2.app and it also does not allow me to finish with Ctrl-s. –  Bret Moore Sep 7 '11 at 18:58
    
If you do -M-x describe-key and do C-s (ie. I-search) does it work? It certainly sounds like something is bound to C-s at a higher level than the Terminal.app. –  Slomojo Sep 7 '11 at 23:42
    
@slomojo I attempted to C-s while M-x describe-key. It does nothing. On another note, I created a new account and tried to test it with fresh settings. It worked! The commands work fine. I really don't want to move to a different account over emacs commands, however. So after learning this I have tried turning my keyboard settings to default on regular account(I did not change these, but did reset anyways). –  Bret Moore Sep 8 '11 at 15:44

2 Answers 2

Is it possible that you have a global shortcut associated to the key sequence Ctrl + S ? Such a shortcut would get the sequence before it is sent to the Terminal and it would explain why it doesn't work with Term.app and iTerm2.app.

You can check for registered shortcuts in System Preferences, Keyboard, Keyboard shortcuts. You can also revert them to the default if you think you never changed them.

share|improve this answer

I just ran into what I think is the same problem when trying to use Ctrl-S under Vim in Terminal.app. I found a related tip indicating that by default, Terminal.app reserves Ctrl-S for old-fashioned XON/XOFF flow control. Adding this line to my .bash_profile -- or just entering it at the prompt -- freed up Ctrl-S and Ctrl-Q for use with Vim:

stty -ixon -ixoff

share|improve this answer

protected by Daniel Lawson Apr 10 '12 at 4:21

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.