Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have an NTFS drive in my mac and use paragon to read and write from it. All good. I now want to share it with my windows 7 pc. I did this by using the "File Sharing" feature in System Preferences.

I can access the shares on the HFS drive but not the ones on the NTFS drive. Any help would be awesome. Windows just tells me:

"Windows cannot access \192.168.1.150\d" Details: 0x80070035 (path not found)

share|improve this question

2 Answers 2

I think you will find that you are unable to do this. I mac can read from an NTFS drive, but it cannot write to it. Thus, it cannot make changes to the permissions on the drive in order for for file sharing to work.

Sorry about that.

Does the drive need to be in NTFS? Could it be formatted Fat32 instead? Then you should be able to read and write to it from both the Mac and Windows machine.

share|improve this answer
    
It certainly can write to it, if you get one of a few available third-party drivers. (Example: macntfs-3g.blogspot.com ) I suggest the OP try some tools other than paragon (demo or at least one is freeware) to see if they work better. There are certainly reasons to choose NTFS over Fat32. –  Andrew Lazarus Sep 8 '11 at 23:44
    
Yes, But if the third party utility isn't integrated with file sharing, there will still be no way to write to the device. -- also, yes, there are good reasons to use ntfs over fat32, but what's the priority here? File sharing, or NTFS formatting? –  TheWellington Sep 8 '11 at 23:51

This is the reason why you can't share your NTFS drive from OSX to Windows: In OSX Lion Apple replaced the open source samba with apples own version which unfortunately ignores anything that isn't hpfs. So it hasn't anything to do with your drivers or such.

This topic was discussed at length at MacRumors. The proposed solution is to install XCode and MacPorts followed by

  • sudo port install samba3
  • Navigate to /opt/local/etc/samba3 and modify smb.conf to your needs
  • Disable File Sharing in System Preferences
  • Launch smbd & nmbd daemons: sudo /opt/local/sbin/smbd -D && /opt/local/sbin/nmbd -D
  • To have smbd/nmbd launch automatically during boot you may also need to add an appropriate launchd file.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.