Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On a couple occasions since I installed Lion, the keyboard shortcuts + and + have stopped working to navigate to the beginning/end of a line inside text fields and such. Any ideas what's going on?


  • My computer doesn't beep when I hit these shortcuts.
  • Keyboard Viewer shows that when I hold down , pressing left/right doesn't do anything.
  • When I hold down both and , the arrow keys work fine.
  • The left and right arrow keys still work by themselves.
  • + and +, and +arrows still work.
  • +A and +E still work.
  • I don't have any particularly weird custom keyboard shortcuts set up.
  • If it matters, I use 4-finger swipes and +arrows for switching desktops, two- and three-finger swipes for navigation, and three-finger swipes for Mission Control & App Exposé.
share|improve this question
I have exactly the same problem. – Semyon Perepelitsa Oct 8 '11 at 7:27
up vote 3 down vote accepted

I've noticed that certain applications seem to trap the gestures, even when they're no longer active.

The only time I've been able to 100% narrow down something trapping various shortcut keys was with either Apple Remote Desktop (the built in screen sharing functions), or Microsoft Remote Desktop.

Even though I clicked outside of the app and started using something else, something caused notably my ctrl+/ to stop working.

I unfortunately do not remember the specific steps I took to resolve the issue. Whether it was explicitly sending focus into the remote connection window, and then (with the mouse only) explicitly out of the window, and onto another app that is not just the Desktop, might have fixed the problem. Otherwise, I may have just closed the window in frustration.

Either way, this issue is one that you may have to do some personal diagnosing to figure out. Check for any running apps that are notably not native (Java, AIR-based, etc.), or have some other form of deep integration (trapping keyboard events and sending them to another computer is pretty deep), that may be causing this issue.

share|improve this answer
Based on the other answers, it looks like Mission Control is also one of the culprits. – benzado Mar 1 '12 at 19:48
The flash plugin is also a great trapper of shortcuts – Agos Mar 1 '12 at 20:34
I've never had a flash plugin trap something when that browser tab isn't in the foreground. But yes, when a flash applet has focus, it often will prevent mission control / exposé style key movement. – Jason Salaz Mar 1 '12 at 20:49
full screen flash playback seems to be the cause on a regular basis for me. Enter full screen, play it for a bit, exit full screen, boom no more command+arrows. – cabbey Mar 22 '12 at 23:05

No need to restart, these steps helped me:

  1. Swipe 4 fingers up to show Mission Control
  2. Select a full-screen app in the list of desktops
  3. Swipe 4 fingers up to show Mission Control again
  4. Select a text editor app on the main Desktop
share|improve this answer
I have my "show Mission Control" gesture set as 3 finger swipe up, but otherwise this worked. Thanks! – ordord00 Dec 30 '11 at 19:30
Wow I really didn't think that was going to work but it did! I didn't have to select a full-screen app on step 2, just any app and it did the trick. Really strange bug this one. At least now I don't have to restart each time it happens! – mattjgalloway Jan 17 '12 at 10:05
This works for me too, thanks! – Mikhail Korobov Jan 19 '12 at 3:31
Worked for me, also didn't even need to select a full screen app, just switched from Desktop 1 to Desktop 2 and back. – benzado Mar 1 '12 at 19:48
WTF, this really works :) What a strange behavior. – pre May 9 '12 at 6:38

I just had this problem as well, for me, this thread on worked.

The solution proposed there is to restart the Dock. To do so, type the following in the Terminal:

killall Dock
share|improve this answer
This worked for me! – Diego Mar 16 '12 at 3:10
simple, fast, and worked. nice solution! – netricate Mar 20 '12 at 14:31
This worked for me too. Thanks! – dmonopoly Mar 23 '12 at 23:58

It’s the second time I have this problem. This first time I restarted. Today I found your question and saw your remark about finger swipes. I switched desktops (I use two-finger swiped on the Magic Mouse) and now +/ works again.

I don’t know if it will work again next time, but it’s worth a try before restarting.

share|improve this answer
I have this problem today and solved thanks to Oliver, swipe (two fingers) on browser solve the problem XD – user18621 Feb 12 '12 at 7:59

I saw the answer from Olivier, and the desktop switching gesture did not solve my problem. I ended up doing the gesture to show the mission control (for me, 3-fingers swipe up), and after that + started working again.

Update 12/8/2011: This has resurfaced for me again and sure enough using the gesture to show and close mission control solved it!

share|improve this answer

I've experienced the same problem since upgrading to Lion and found that it works ok again after a system restart.

share|improve this answer
overkill. This isn't Windows. – cabbey Mar 22 '12 at 22:34

protected by Community Feb 20 '12 at 17:55

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.