Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I don't know if there are any settings to toggle, but I figured out that if I keep pressing a button on my keyboard it doesn't repeat it and displays only one character! Can this be fixed to go back to the previous repeating behavior?

share|improve this question
    
oddly e, u, o, a, s, ö, ä, ', <, z, ,, ., -, §, +, , , + arrow & control keys aren't affected; or if any key is pressed together with any control key. (I have Finnish Apple Wireless Keyboard) –  koiyu Sep 1 '11 at 9:27
1  
I think that Kreker means that in Lion, when you hold down a key that has alternate values (such as an "e" with and accent, a new menu will appear above the letter allowing you to choose the modified character. I agree with Kreker, it seems silly then for the System Prefs keyboard pane to have key repeat settings when they don't apply. It seems like there should be a choice between the "context" menu and key repeat or a way to make them work together. I verified this behavior in Word, Excel and TextEdit. Seems like maybe a Lion oversight or something in need of UI enhancement. –  user10950 Sep 12 '11 at 22:20

1 Answer 1

up vote 13 down vote accepted

This is a new "feature" that Apple introduced in Lion. To disable no key repeat, enter

defaults write -g ApplePressAndHoldEnabled -bool false

in Terminal, and then restart your computer.

Source: https://discussions.apple.com/message/15678809

share|improve this answer
    
ok thanks! But why I don't see the new context menu that was implemented in Lion? I don't know either why apple leave the "repeat time" in the system keyboard preferences –  Kreker Sep 1 '11 at 9:02
    
sorry, i can't understand what you mean by 'new context menu.' could you possibly describe this further? for the 'repeat time,' you can go into system prefs -> keyboard -> and it defaults to the keyboard shortcuts tab. go to the keyboard tab and you'll see more options –  Ethan Lee Sep 1 '11 at 19:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.