Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My iPad is really starting to infuriate me. My Google/iPad calendar sync has been working perfectly for months, but not it won't. In Google Calendar I've removed a few now superfluous calendars and added a new one to keep track of my classes. This new calendar just won't friggin show up in iPad. I've visited the Google sync page for devices and everything is set up correctly. All my calendars are checked. But out of my 3 checked calendars, only 2 of them show up in iPad calendar.

I've tried removing my Gmail account from the iPad and re-adding it with no results.

Any ideas?

Debug progress: I've tried unchecking all my calendars (Except the mandatory main calendar) in the Google Sync mobile page but they still show up in iPad. I've checked if the current calendars in iPad are synced, and they are indeed. I've also tried creating a new calendar with a few events on it and adding it to the iPad sync list via the google sync page. It doesn't show up on the iPad. So to sum up, the aforementioned sync page no longer has any control over which calendars are synced to my iPad.

Help still needed!

share|improve this question
I'm experiencing similar problems & I found this page… It says here that it's a known issue, hoe they fix it soon. – Samantha Catania Sep 16 '11 at 20:27

I had the same problem. I unmarked to sync the calendar (deleted all events from the iPad) and then marked back to sync, and all got back to work.

share|improve this answer
That was one of the first things I tried. Annoyingly only the calendars that were syncing previously were added afterwards :3 – Hubro May 10 '12 at 11:55
@Codemonkey How many calendar and how many accounts are you tring to sync? And which are(n't) syncing? – Tom Brito May 10 '12 at 14:08
It just happened again to me. I tried turning the sync on and off 3 times, and I let the calendar app in the front, so it could stay trying to synchronize. Also, I used the link provided by @BradleyChambers (in the other answer) while trying. Now it's working again :) – Tom Brito Jun 12 '12 at 1:30

This is a long shot, but have you tried this:

share|improve this answer
I had not, but I have now. No difference in my problem. How was it supposed to help? :-) – Hubro Aug 30 '11 at 15:12
I've seen that tool fix some weird syncing problems before. – Bradley Chambers Sep 29 '11 at 18:54

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.