Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just cannot get Rails to work on my 10.7.1 Server installation. After having run CC=/usr/bin/gcc-4.2 gem install rails --force as root, I still get this:

% rails
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:777:in `report_activate_error': Could not find RubyGem rails (>= 0) (Gem::LoadError)
  from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:211:in `activate'
  from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:1056:in `gem'
  from /usr/bin/rails:18

RVM doesn't appear to be producing a working install either.

To cap it all, this lack of Rails is preventing Profile Manager from running.

Does anybody know what could be going wrong here? I've tried a clean install of 10.7 (not Server, though) on another machine, and Rails runs fine in that. I'm not particularly keen on nuking and reinstalling my main system, though!

share|improve this question
try upgrading rubygems or try uninstalling rails and installing using gem gem update --system ; gem uninstall rails; gem install rails – Sairam Aug 28 '11 at 12:50
Thanks — that seems to have fixed things. If you put that as an answer rather than a comment I can mark it as accepted. – John Yeates Aug 28 '11 at 16:57
up vote 2 down vote accepted

Try upgrading rubygems or try uninstalling rails and installing back again using gems.

gem update --system 
gem uninstall rails
gem install rails
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.