Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I was told that I could open a .CSV file with Excel. However, my Microsoft Excel refuses to recognize the file.

I have tried my different ways to open it in Excel but the program didn't give me a choice to click the file open.

I am using Mac 10.4 and the Excel version is Microsoft Excel X for Mac.

share|improve this question
1  
Since CSV (comma-separated value) files are plain text, it might be worth trying to open it in TextEdit first, to make sure you really are dealing with a CSV file. –  scottishwildcat Aug 26 '11 at 16:55
    
Can you choose the file in Finder and then Open it (and what does Open With..) show? –  Mark Sep 13 '12 at 12:59
add comment

2 Answers

Assuming you have a valid/consistent CSV file, create a new workbook and then choose File -> Import. The first option on the list is "CSV file":

enter image description here

share|improve this answer
    
Thank you for your answer. I appreciate it. However I checked my Excel, there is no Export function anywhere, including the File tab. Please could you advise me again. –  FandW Aug 29 '11 at 14:43
    
Sorry, not familiar with the old version of Office for OS X. Mine is 2008. –  EmmEff Sep 11 '11 at 16:01
1  
@FandW - the answer was to use Import not export –  Mark Sep 13 '12 at 12:58
add comment

Here's a way to force any app to open any document :

  1. Make sure your Dock is visible.
  2. Select your .csv file in the Finder
  3. Grab it with your mouse and move it over the Excel icon in the Dock. Do not release the mouse button.
  4. Hold the Command and the Alt key on your keyboard
  5. Release the mouse button.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.