Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have recently upgraded to OS X Lion. I have mapped the keys via Mission Control preFpane as follows: F9 is 'Mission Control', F10 is 'Show Desktop'. F11 is 'Application Windows'

F9 and F11 works as intended. F10 seems to not do anything.

I thought it might be the keys themselves so I mapped the keys as: F9 'Show Desktop', F10 'Mission Control' and F11 'Application Windows'.

In this case only F10 and F11 keys worked; This small test gives me the impression that it is the Exposé 'Show Desktop' function itself is the part that is malfunctioning.

Does anybody have any further insight to this bug?

EDIT
You can view a recording of the problem here: http://www.screencast.com/t/oDVMhBqkb

NOTE

This problem was tested initially on my external keyboard, the problem does persist on the internal macbook keyboard. Those '4 finger swipe' works, as does the 'Cmd + Expose(f3)' keyboard shortcut work.

share|improve this question
1  
The most likely cause is actually a corrupt preference file storing all the shortcuts. If you make a new user and test this one change, does the software work properly? If so, you might have to restore all shortcuts to the default and build up your preferences. –  bmike Aug 24 '11 at 23:36
    
Hmm, you could be right; I'll try that and get back to you. –  jwmann Aug 25 '11 at 14:04
    
deleting com.apple.symbolichotlinks.plist did it for me - worth trying that first if you value your dock setup! –  Homer Jun 13 '13 at 19:21
    
@Homer Do you mean ~/Library/Preferences/com.apple.symbolichotkeys.plist? –  ؘؘؘ Jun 13 '13 at 19:38

3 Answers 3

I've solved this by deleting following plist files in ~/Library/Preferences. By default, they are hidden. Warning! Your Dock will revert to default state. Shortcuts and everything else will remain.

com.apple.dashboard.plist
com.apple.dashboard.plist.lockfile
com.apple.desktop.plist
com.apple.desktop.plist.lockfile
com.apple.dock.plist
com.apple.dock.plist.lockfile
com.apple.dock.3A51CCF9-CDE4-5F17-8CFB-FF648B8A6CDF (or similar)
com.apple.dock.3A51CCF9-CDE4-5F17-8CFB-FF648B8A6CDF.plist.lockfile

At my system (fresh 10.7.2 installation), this affected only Function keys (F1 row). I still could set Show desktop to Modifier keys or Mouse buttons.

share|improve this answer

Restart Dock, of which Mission Control is a child process. In terminal, run:

killall Dock

share|improve this answer

I recently used MLpostfactor to upgrade my 2007 MacBook to Mountain Lion 10.8.3 from 10.7.5. Since this is officially unsupported, I had a few glitches. The most annoying was that Mission Control would display, but showed NO spaces and would not allow any to be added. Deleting the preference files in the answer fixed my problem. Mission Control now works completely. This is the only reference I have located on deleting the Mission Control preferences.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.