Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

After upgrading to Lion, I have no sound at all under OS X. It doesn't come through my speakers or through my headphone jack. I've checked in the Sound preferences, and it's set properly. I've tried killing coreaudiod, which does nothing. I've triple-checked that I'm not muted (I'm not) and the volume is up (it is), and I've made sure I'm upgraded to 10.7.1, since that was supposed to resolve some sound issues. There's just nothing.

The good news is that I know that the hardware's not broken, since my Widows BootCamp partition works just fine. The bad news is that I don't want to boot into Windows to listen to iTunes.

What am I missing?

share|improve this question
    
Have you rebooted? –  jtbandes Aug 24 '11 at 17:00
    
Yep. Several times. I had to in order to realize sound was working properly in BootCamp, after all. –  Benjamin Pollack Aug 24 '11 at 18:54

3 Answers 3

up vote 1 down vote accepted

Odd though it may seem, try launching Garage Band (if you have it) and creating/saving a new project. It seems that Garage Band does some low-level tests on your audio system when it runs, and clears up weird states like you're encountering.

This doesn't answer the question of what's wrong, but hopefully will fix it anyhow.

share|improve this answer
    
I honestly don't even want to know why that worked, but thank you for the incredibly unintuitive suggestion. –  Benjamin Pollack Aug 29 '11 at 21:00

I had a similar problem start when I upgraded to 10.6.8 with external speakers connected via the headphone jack (MBP). When I switch users (Fast User Switch) audio is dead in that other user and fine in the main user.

  • The first solution I found was to unplug and replug the headphone jack.

  • The second and more convenient solution is to:

    1. Open the "Audio MIDI Setup" application (/Applications/Utilities/)
    2. Switch the Format: Channel/Bit dropdown to something other than what's currently selected and then back to what was there when you first opened it. (ex: 2ch-16bit -> 2ch-20bit -> 2ch-16bit).

      The first change is what does the trick. That seems to restart whatever audio system is crapping out.

Obviously you shouldn't have to do this, but it's the best workaround I've found in the mean time.

share|improve this answer

If the GarageBand effort does not fix it, try starting in Safe mode, then restart normally when you see the login page.

Starting in Safe mode essentially does a Disk Repair during the boot process, and a lot of extras are disabled.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.