Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I just spent a good hour on Mail app, and its pissing me off.

First archive button is dumb, it actually creates a label called [imap]/archive.

Sending messages is dumb, it actually creates a label called 'Sent Messages'

Deleting messages is dumb, it actually creates a label called 'Deleted Messages'

I don't understand how can the iOS version work well, while the Lion version behaves completely different. Does anyone know how can I get around these problems? My current solution is to use Sparrow. I have also tried looking around the stackexchange websites (superuser and apple), Apple forums, MacRumors, Google, etc..

Other topics with no solutions: How do I get archive to work in Mail.app in Lion? http://superuser.com/questions/315171/how-to-stop-mail-app-in-lion-creating-an-archive-folder-for-archiving-in-gmail

share|improve this question
    
This is a common question that's been asked here many times. –  Wheat Williams Feb 28 '12 at 23:42
add comment

3 Answers 3

Gmail is not exactly IMAP so needs some manual configuration

You need to go in Mail to the folders under your Gmail account and on Trash/Sent Messages/Deleted Messages/Junk select each one of these and then in Mail choose Mailbox > Use This Mailbox For the corresponding Draft/Sent/Trash/Junk.

I originally did this from a very clear set of instructions that I cannot find now. However another set are here.

I also go to the web Gmail Settings and turn off the Show in IMAP check box for the All Mail tag. This means that I only sync one copy of each mail to the Mac.

share|improve this answer
add comment

http://www.macworld.com/article/157846/2011/03/mailgmail.html

They at least discuss what the different choices do alongside their suggestions, which allows you to pick and choose what features you want.

They also show you how to set up IMAP folders with Gmail Drafts, Sent Mail, Trash, etc so you don't have duplicates there (essentially, select the mailbox in Apple Mail. Mailboxes >> Use this mailbox for >>)

Hope this helps! It was really frustrating for a while for me, too.

share|improve this answer
    
This article at MacWorld has some really good advice. Be aware that it was written some time ago and the features that it explains as "advanced IMAP controls" and "experimental" have now been promoted to the general user preferences by Google. –  Wheat Williams Feb 28 '12 at 23:43
add comment

User fails to grok Mail 5 on Lion with Gmail? The solution is to use Sparrow.

If you go into System Preferences under Mail, Contacts & Calendars; setting up using Exchange for active sync works better than using the gmail setting in some cases. You might try the other setting if your current one is failing you.

share|improve this answer
    
GMail, of course. Should I be using Exchange? –  Doug Aug 24 '11 at 6:14
    
For contacts syncing on your iPhone. I use Exchange for that. Did you try deleting the account and re-adding it? –  wjl Aug 24 '11 at 6:43
1  
Gmail with Exchange doesn't work on a Mac - but is does on iPhone/iPad (and so far only there) –  Rene Larsen Aug 24 '11 at 16:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.