Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My Drobo that acts as my media server and Time Machine host for my family's Macs has become read only. While this would normally be a nuisance, it's become a real problem in that I can't change it back from the Get Info Window I've also tried chmod +w to no avail. Any hints on what to do?

In the attached photo, you'll see that the options are dimmed and say that I should have access, but the disk is still read only.

Get Info Window

share|improve this question
up vote 1 down vote accepted

I would suggest following the official support guide for this issue available here:,-connected-to-my-mac,-suddenly-read-only-and

share|improve this answer
Thank you. That solved my problems. I'd restarted a number of times but had not physically unplugged the unit. – evansb2 Aug 24 '11 at 7:47

what did you do? did you use disk warrior? this has happened to me now, Nov 2013 on Drobo 5D. Disk warrior did not work and so Im having to move all my work over. A real pain. I hate drobo now. drobo got me to purchase Disk warrior so down 80£ and still had to buy extra drives to move all this work off it.

share|improve this answer
Should this be a comment on the answer from Lyken or perhaps an edit to the question? – bmike Nov 6 '13 at 23:01

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.