Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I am trying to install Rails 3, but having trouble with sqlite3. First I tried

$ sudo gem install sqlite3

however, I got this error message: http://pastie.org/2419493

After googling around, I found a few things about installing/reinstalling the sqlite3 package in MacPorts. So I tried this:

$ sudo port selfupdate
$ sudo port update outdated
$ sudo port clean sqlite3
$ sudo port install sqlite3

Then tried the same gem install command above. Same problem. Here are my versions on the command prompt:

$ ruby --version
ruby 1.9.2p290 (2011-07-09 revision 32553) [i386-darwin9.8.0]
$ rails --version
Rails 3.1.0.rc6
$ gem --version
1.8.8
$ sqlite3 --version
3.7.7.1 2011-06-28 17:39:05 af0d91adf497f5f36ec3813f04235a6e195a605f

I can find other reports of this problem on google, but so far none with solutions that work for me. Any ideas?

Edit: For troubleshooting, I tried running Combo Update 10.5.8, then repeating the above steps. Still no dice :-/

Edit 2: The executables ruby, rails, gem, sqlite3 are all installed through port. That's because I didn't want to mess with the binaries that came with OS X, but I wanted the updated versions. For instance, doing

$ which {ruby|rails|gem|sqlite3}

results in

/opt/local/bin/{ruby|rails|gem|sqlite3}
share|improve this question
    
sqlite3 shipped with Leopard so can't you just update your ruby bIndings with sudo gem update sqlite3-ruby –  bmike Aug 24 '11 at 0:46
    
When I try, I get:Updating installed gems Nothing to update –  Robert Martin Aug 24 '11 at 0:58
    
Silly question: did you install the Mac OSX Developer Tools? –  ghoppe Aug 24 '11 at 1:50
    
Yes, I believe so. I got xcode and all that goodness –  Robert Martin Aug 24 '11 at 2:20
    
Well, I gave up. To avoid this problem entirely, I bit the bullet and updated the binaries in /usr/bin/* instead of using the ones from MacPorts. I guess that something in 'gem' is demanding to look at the built-in versions even though I don't want it to –  Robert Martin Aug 24 '11 at 2:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.