Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have an iPod Touch -- my first iOS device -- and I'm trying to figure out how to set up the keyboard layouts, because I'm going to be typing almost exclusively Japanese.

I went into the preferences, added the Japanese 10-key, added the Chinese (traditional) handwriting recognition, and removed all the others. (I'm indifferent to the emoji keyboard layout, since it doesn't ever seem to appear, even when it's in the list.)

After a few minutes of using my iPod, the keyboard settings will have automatically changed. The Japanese romaji keyboard will have been added, and the Chinese handwriting will have been replaced with the English keyboard.

I find this confusing and frustrating. If I add these extra keyboards myself, then it doesn't muck up my preferences, but then I have a bunch of extra keyboards I'll never use, including the default keyboard.

I've been trying for a couple days to find a pattern (a particular app or operation that causes the keyboards to spontaneously change), but I've not found a smoking gun yet. One symptom is that when the keyboards change, when I go into the preferences, it's back at the top of the main screen, instead of wherever I was last (regardless of whether I was in the keyboard settings or not) -- but I don't know the significance of that.

So a few questions about this:

  • Is this new in iOS 4 or 4.1? Is it the sort of thing that Apple would recognize as a bug and fix in 4.2 (or even 4.1.x)?

  • Is there a workaround? (I'm completely new to iOS so I haven't figured out all the workarounds for the OS bugs here yet!)

  • Is there a way to set the default keyboard? (This wouldn't be nearly as bad if I could make the Japanese 10-key the default keyboard, but whenever 'English' is in the list, it makes itself the default, no matter where it is in the preferences list.)

Thanks!

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

I bit the bullet and upgraded to 4.2. After upgrading, I removed all but the 2 'keyboard' layouts I wanted.

I've been running it for a whole day now, and it hasn't spontaneously changed my keyboard settings. I'm going to call this one a bug in 4.1 that got fixed in 4.2.

Yay!

share|improve this answer
add comment

Try resetting your settings (note just your setting, not setting & content) My friend's iPod Touch also kept resetting its music settings, resetting all settings solved that. Note resetting settings will remove any clocks you added to the clock app and remove any timers you had running.

Reset can be found in the settings app -> general -> reset (right at the bottom) -> reset all settings (the first one)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.