Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Well, I left it plugged in via USB and charging. iTunes was open. Nothing unusual. Until an hour or so later, out of the corner of my eye, I noticed a zooming shiny apple animation, picked it up and was prompted to "Set up my iPhone". Ugh. I haven't backed it up for 10 days or so and there's stuff on there I really want to keep. So I went through the setup, enabling location, selecting my router, and then trying to activate the phone, all the while hoping once completed everything would be just as I'd left it, right as rain. But I can't get past the activation stage. And when I opt to activate through iTunes, iTunes complains that the iPhone's software is too old. At this point I should mention I'm a registered developer, and my iPhone was running iOS 5 beta 3.

When plugged into iTunes it displays 8.7 GB of space taken, all marked as "Other", and it's still on build version 9A5259f, i.e. beta 3. So I'm reasonably optimistic my precious data's still on there. But I can't use it to see. And when I try to back it up now, nothing happens.

I'm guessing this could be because beta 3's expired? Maybe? I didn't get around to updating it because for some reason over the air updates wouldn't work. Any advice on what my next move should be would be very greatly appreciated!

share|improve this question
Mine just did the same. I'm also a developer with iOS 5 beta 3. Execpt in my case, it wasn't plugged in... it just stopped working. – user10088 Aug 19 '11 at 1:26
Ahhhh! Ok that makes sense. Was there ever any warning from Apple this was going to occur? I've so far managed to back up all my photos with iPhone Explorer. Going to look into jailbreaking to get root access to see if I can get at anything else. – Alec Aug 19 '11 at 1:33
no warning, which is a bummer. I won't have access to a mac for two weeks. I made the mistake of using it as my primary phone, too. – user10090 Aug 19 '11 at 2:29
Be careful jailbreaking the beta too; it's only tethered, and it's VERY unstable. – Thomas Aug 24 '11 at 14:04
"And that's why you don't use OS betas on your main devices" --J. Walter Weatherman – Dan Ray Aug 26 '11 at 12:26
up vote 2 down vote accepted

After 14 hours of research and experimentation I recovered everything. Here's how:

I used iPhone Explorer to back up all of my photos.

I jailbroke with redsn0w.

Explored the filesystem with iPhone Explorer, and tried to copy the whole root filesystem (which, for some unknown reason, silently missed quite a few files, but oh well).

Saw that both sms.db and all my application data were still intact. Danced with joy.

Removed the ReleaseType -> Beta key in /System/Library/CoreServices/SystemVersion.plist

Restarted it, set it up as a "new" iPhone, and all my sms, apps, etc were still there. Hurrah.

Set my PC's date to a week ago.

I then backed up in iTunes, and restored to the latest beta.

Photos, notes, sms were back on there, apps were all deleted but app data remains, so it's just a matter of re-downloading the apps.

I love a happy ending :)

share|improve this answer

I had a similar problem with beta 5. Updating to beta 6 brought all my stuff back.

share|improve this answer

My next move would be to get a free trial of PhoneView and see what is still recoverable. If no Mac OS X machines are handy, the PhoneView FAQ has a windows recommendation for that OS.

Even when iTunes/Xcode feels the device needs a restore - the phone log, contacts, and all sorts of data may very well still be recoverable.

You don't have to pay for the software until you're sure you can get some of the data off. I believe it's a 10 item limit - but do check it out.

I've had non beta iOS devices up and crash like this - just par for the course with flash memory and software. Sometimes it just takes a big digger.

share|improve this answer
Thanks for the tip, I've just tried PhoneView. It sees my Music, Photos and Voice Memos fine, but fails to load my Contacts, Notes, Call Log, Messages, Web and Voicemail with the error "Unable to Download". I'm looking into jailbreaking to see if I can just get root access to dump everything. – Alec Aug 19 '11 at 1:45
Normally, jailbreak only allows accesss to the root filesystem. You've already gotten full access to the contacts and other data, so it's worth a shot - just know it's a long shot. My fingers are crossed – bmike Aug 19 '11 at 1:58

protected by patrix Sep 25 '13 at 10:04

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.