Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

On my new iPhone 4, I can add a new contact after talking to them (Add as new contact) but I cannot otherwise add new contacts, or edit existing ones.

It looks like a bug. Is there a way to work around it, or do I have to wait for Apple to fix their issue? The phone is not jailbroken.

share|improve this question
    
I'm not sure I understand your question. Can you add some more detail please? I can add and edit contacts just fine with my iPhone 4 as I did with my 3G. –  Thomas Jul 15 '10 at 12:46
    
Perhaps it is because I restored a backup from my old 3GS to the new phone? Either way, the + button in the Contacts app isn't there, and neither is the Edit button when I look at a contact... –  Allan Mertner Jul 16 '10 at 18:48
    
There is an issue. When going through the contacts app I am unable to add, edit or delete contacts. I also tried going through my text messages to edit the contact from there and was unable to. But if I go through the phone app and select favorites or numbers that I have recently called, then I am able to edit those contacts. Is this a minor glitch? Before the new software update to my iPhone 4 I was able to edit contacts through selecting my contact book and through txt messages. –  user12238 Oct 17 '11 at 17:28
    
Make sure Contacts is closed and removed from the multitasking menu (double tap home button). Then open it and take a screenshot (power + home button). Post that screenshot please. –  cksum Oct 18 '11 at 1:37
add comment

5 Answers

You can use the Contacts application provided in the iPhone 4, and create/edit contacts in there.

share|improve this answer
    
On a brand-new iPhone 4, the Contacts application is the only built-in application on the second app screen. Swipe to the right and you should see it. –  BradC Jul 15 '10 at 22:47
add comment

What's preventing you from doing so?

The ability to add and edit contacts from the phone app is still available. I tested this just now on mine.

share|improve this answer
    
I can't do that; the + button is missing on mine! –  Allan Mertner Jul 16 '10 at 18:47
    
Are you syncing your contacts with any sources? Please check Settings -> Mail, Contacts, Calendars and see if any accounts say "Contacts" underneath. –  Stephen Jennings Jul 18 '10 at 4:54
2  
-1 - how on earth is "it works on mine" a valid answer? (Except, even though I've got 20k+ global rep, I still can't downvote here. So it's in spirit only) –  Mark Henderson Oct 17 '11 at 20:36
add comment

just go to settings > Mail, Contacts, Calendars > if there is a accont (hotmail, g mail etc.) just delete the account and then automatically you can start adding contacts

share|improve this answer
    
an anonymous commenter adds this: " this just deletes your mail account... see below answers regarding icloud settings for IOS5 and above... I followed this step and now having to re-configure my mail settings...." –  Kyle Cronin Nov 3 '11 at 20:49
    
Citing sources is a helpful practice for tips like this. –  Daniel Lawson Nov 9 '11 at 4:45
add comment

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

It seems that the problem occurs when adding contacts to these phones after updating to IOS 5 (the + sign on the corner right is missing). IOS 5 added iCloud and if your contacts are not turned ON from the iCloud settings, you won't be able to add, edit or delete contacts.

The Fix: turn ON your iCloud contacts settings from Settings > iCloud and you should see your + sign on the corner back again.

share|improve this answer
add comment

I had the exact same problem. Go to settings, then iCloud, go to the 'contacts' switch and set it to 'on' and it will fix your problem immediately.

share|improve this answer
add comment

protected by Community Oct 24 '11 at 14:06

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?