Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

So the default scrolling behavior for the trackpad in Lion is to scroll in the direction of your finger movement similar to the iPad. This can be changed in the trackpad preferences by un-checking Scroll Direction: natural. I get that part. My problem is that un-checking or checking this box in the trackpad settings also causes the box in the mouse settings page labeled Move content in the direction of finger movement when scrolling or navigating to be checked or un-checked - effectively tying the mouse scroll wheel behavior to the trackpad scroll behavior. Is this a bug?

I want to be able to scroll with the trackpad in the default Lion way while still being able to scroll with a mouse wheel in a conventional way. Is there a workaround to the above issue to be able to do this?

share|improve this question
2  
No it's not a bug. They are linked. –  user479 Aug 17 '11 at 5:15
    
At the very least the display of the checkbox value is bugged, so this probably will be fixed to some degree in the future. Wether they'll remain linked I don't know. –  Gerry Aug 17 '11 at 7:29
    
That's disappointing. I like the natural scrolling with the trackpad but I have a normal scroll wheel mouse which doesn't feel right with the natural scrolling. –  Tom Aug 17 '11 at 13:21

4 Answers 4

up vote 11 down vote accepted

There is a workaround, and it is called Scroll Reverser. That screenshot says it all; you can invert scrolling per-axis and per-device.

share|improve this answer
    
This is cool. I was hoping for a native solution but this is enough of a work around that I'll mark it as the answer. –  Tom Aug 30 '11 at 16:39
    
It doesn't work on Mavericks –  lorenzo Jan 22 at 13:54
    
It works for me on Mavericks. Are you sure you downloaded version 1.6, not the older version 1.5? In what way doesn't it work for you? –  75th Trombone Jan 24 at 2:43
    

Yes there's just one setting for all input devices.. It's a pity because the natural scrolling doesn't work as well with regular scroll-wheel mice. It works great with an Apple Magic mouse, in my experience. Hopefully someone will find a hack for this.

share|improve this answer
1  
The 2 different settings are actually linked, though not visually. Unchecking one will disable natural scrolling for all devices. –  Gerry Aug 17 '11 at 7:30

tell application "System Preferences" activate set current pane to pane "com.apple.preference.trackpad" end tell

tell application "System Events" tell process "System Preferences" click radio button "Scroll & Zoom" of tab group 1 of window "Trackpad" click checkbox 1 of tab group 1 of window "Trackpad" end tell end tell

tell application "System Preferences" quit end tell

Try this - you can have a small script/app on your desktop for switching scrolling from natural to the old one. As soon as I plug in my USB mouse i just run this script ale everyhting is set up.

share|improve this answer

I was able to set up ControlPlane to automatically toggle OS X natural scrolling on/off when I switch between using my trackpad & mouse.

I outlined exactly how to set it up step-by-step in this blog post: http://kellenmace.com/automate-trackpad-mouse-natural-scrolling-in-mac-os-x/

I looked at Scroll Reverser also, but the developer describes a few downsides to using it on his website that I wanted to avoid. I'm happy to report that this ControlPlane solution is working perfectly. I hope it helps anyone still looking for a solution.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.