Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When copying files/folders from a share on a Windows server to a share on our OSX (10.4.7 Server) using a Snow Leopard workstation. The Linux workstations get "Access Denied" errors.

All users are using the same credentials.

  • Windows users can access the files on the OSX Server.
  • OSX workstations can access the files.
  • Linux workstations and the (admin) user logged on to the OSX sever itself cannot access the files.

On the OSX server itself, the folder has a little red indicator on it with a line through the icon. Get Info -> Ownership & Permission has "You have [No Access]".

enter image description here

  • I looked into chmod -R -N on the server, but I guess this version of OSX Server does not support then -N switch. Anyway, I would rather get to the root cause.

  • This only happens on files/folders that are copied from a separate Windows server's share. Folders/Files created by the OSX workstations can be access everywhere fine.

  • All copying is being done from the Snow Leopard OSX Workstations.

  • Tried copying the files from the Windows Servers to the local workstation, then copying them to the OSX server, same result.

Any suggestions as to where to begin debugging this? Is there anyway for the Snow Leopard users to copy files from the Windows server to the OSX server without copying permissions? (or ACLs?)

UPDATE: By checking "Ignore ownership on this volume" for the volume in question, I am now allowed to access the folders on the OSX server itself. However the Linux clients still cannot access said folders. And this actually locks out the OSX workstations from accessing said folders.

share|improve this question
    
Windows shouldn't be copying ACLs with the files. Check how you're connecting to the OS X Server from Windows. It may be connecting as Guest, for example. –  user479 Aug 16 '11 at 1:59
    
The OSX workstation is always doing the copying. "From" being the source. The windows server and the OSX server never connect to each other. I'll try to clean that up in the question. –  mxmissile Aug 16 '11 at 19:01
    
Thanks for clarifying. The Guest user might still be a possibility. –  user479 Aug 17 '11 at 3:36
    
no one using a guest account, everyone is loging on with valid credentials –  mxmissile Aug 22 '11 at 3:13
    
What if you copy the files from the NT server to the OS X workstation, then from the workstation to the OS X Server? IE. allow the files to be written to the workstation first, with local OS X perms, then copied over to the server? That would help with working out where the incorrect perms are coming from. –  Alex Aug 22 '11 at 4:10

2 Answers 2

Just open the shared folder in Finder where you want to copy. And open its info tab. In that you will find the permission section at the bottom. In that change the permission to read & write to everybody. I encountered the same problem and I solved it this way. To edit permission you will need super user access.

share|improve this answer
    
Should this be done on the OSX workstations? Or the OSX server? –  mxmissile Aug 22 '11 at 15:52
    
The workstation users get access denied when they try to change the permissions for "everybody". –  mxmissile Aug 22 '11 at 16:57
up vote 0 down vote accepted

This probably should have been asked on the Linux StackExchange. But I figured it out.

Our Linux workstations fstab entry was wrong, changing it from smbfs to cifs and adding the uid=linuxuser option to the entry seems to have fixed the Linux access issues.

This does not fix the folder access on the OSX server itself. However, it is not stopping production so I am not too worried about it right now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.