Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Call me paranoid but my everyday account has no privileges.

I have a 'administrator' account who is in wheel. When I want to perform administrative tasks, I open a terminal and do

su - administrator
sudo ...

This works fine in most situations, except with X11 applications.

sudo xeyes

fails with

Can't open display:

What I've tried:

  • start X11 with the everyday user
  • do xhost +localhost with everyday user
  • do export DISPLAY=:0 with administrator

How can I run a X11 application with the administrator account when my desktop runs with the everyday user?

share|improve this question
Does xhost + work? Or are you too paranoid to try even that? – Jason Salaz Apr 12 '12 at 3:20

Perhaps ssh -X to localhost?

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.