Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I recently updated to Lion, and have found that at least some HTML tagged as <pre> or <tt> shows up looking like this

enter image description here

I've tried changing the fixed-width font in Safari. I've tried rebooting. The same page looks fine in Chrome, and when I copy the text in question out of Safari into BBedit, it looks fine. I'm at a bit of a loss.

share|improve this question
    
I've embedded your picture and removed the "thanks in advance" people will see you offered it and we generally don't sign off / prepend a "dear readers" here in the interest of signal to noise. We vote to thank people for good questions, comments and answers :-) –  bmike Aug 12 '11 at 16:08
    
As to the problem - this usually happens when a font is disabled in Font Book - can you add a comment or edit the question to show this on a site we all can go to - that would let us tell you which fonts to look for in Font Book. –  bmike Aug 12 '11 at 16:16
    
bmike: Macintouch.com as an example. There's a string of spaces wrapped in a &lt;pre> tag below the header that appears as those placeholder characters. I'm currently using FontCase for font management, fwiw, but this is a problem when using Courier (which is a system font, of course) as the fixed-width font. Interestingly, I can view source on macintouch.com and view that normally in Safari, but when I load the the css file for it, that also appears as placeholders. –  Adam Rice Aug 12 '11 at 17:02
    
Excellent - a safe boot (hold the shift when powering on the mac) will rebuild the font database / caches so that might be a great place to start troubleshooting. This is typical find corruption where another app substitutes / defaults to a font without issues. –  bmike Aug 12 '11 at 17:18

2 Answers 2

up vote 0 down vote accepted

From Apple Support Communities:

Restart in safe mode than normal boot. If that doesn't do the trick, run Font Book and validate all fonts.

share|improve this answer
    
Clearing the font cache seems to have done the trick. Thanks. –  Adam Rice Aug 12 '11 at 18:24

This is a known bug. This problem is often because of a bug with Safari 5.1 that appears when you are also using professional font management programs like Linotype FontExplorer and Extensis Suitcase Fusion.

Disable you font management program, clean your font cache, reboot, and check with the company that makes your font management program and see if they have a new update to address working around this new bug.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.