Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm trying to install ImageMagick on Mac OSX 10.7 and I'm getting the following errors:

When I try to run the suggested verification

$ convert logo: logo.gif
dyld: Library not loaded: /System/Library/Frameworks/OpenCL.framework/Versions/A/Libraries/libclparser.dylib
Referenced from: /opt/local/bin/convert
Reason: image not found
Trace/BPT trap: 5

$ identify logo.gif
dyld: Library not loaded: /System/Library/Frameworks/OpenCL.framework/Versions/A/Libraries/libclparser.dylib
Referenced from: /opt/local/bin/identify
Reason: image not found
Trace/BPT trap: 5

When I try pretty much anything...

$ identify -version
dyld: Library not loaded: /System/Library/Frameworks/OpenCL.framework/Versions/A/Libraries/libclparser.dylib
Referenced from: /opt/local/bin/identify
Reason: image not found
Trace/BPT trap: 5

I've followed the path and it looks like the libclparser.dylib is missing from the OpenCL.framework, but I'm unsure of where to find that or how to replace it, or even if that's the right thing to do.

share|improve this question
2  
How is installing a library not programing related? Maybe this should be migrated to apple.stachexchange.com? –  Ben Aug 3 '11 at 21:39
    
Or SuperUser ... it shouldn't have been just closed. –  Final Draft Aug 12 '11 at 3:13
add comment

migrated from stackoverflow.com Aug 12 '11 at 5:53

This question came from our site for professional and enthusiast programmers.

3 Answers

up vote 18 down vote accepted

Here's what I did to fix this.

  1. Booted up my old machine running OSX 10.6.
  2. Copied /System/Library/Frameworks/OpenCL.framework/Versions/A/Libraries/libclparser.dylib from 10.6 computer into the same folder on 10.7.

Now things seem to be working fine.

Note: the file can also be found here:

share|improve this answer
1  
Great, that worked for me too! Thanks for posting it. –  Konstantin Gredeskoul Aug 8 '11 at 21:31
    
I copied my old file from a backup but it bummed out. The download link worked a treat. Thanks! –  Rimian Jan 4 '12 at 10:42
    
Thank you for addressing to my answer –  workdreamer Jan 11 '12 at 9:07
    
Can someone please re-upload ? The link is broke :( –  Sveatoslav Circel May 3 '13 at 23:00
add comment

If you're using Homebrew, try the following command:

brew doctor

to diagnose the common problems.

One of it could be to remove DYLD_FALLBACK_LIBRARY_PATH variable from your ~/.profile if you have it.

Or you have to re-install libtool by:

brew reinstall libtool --universal && brew unlink libtool && brew link libtool
share|improve this answer
add comment

The top-voted answer on http://stackoverflow.com/questions/6764176/lion-10-7-not-supporting-convert1-dylib-error (minus the first two steps) worked for me — so basically just

  1. brew uninstall imagemagick
  2. brew update
  3. brew install imagemagick
  4. (optionally) brew doctor and follow the instructions

I did have to manually delete some files, but brew doctor tells you which ones. The order of uninstall, update, install, doctor probably isn't important.

share|improve this answer
    
brew doctor checks things are OK so do first –  Mark Jul 27 '13 at 21:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.