Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

For the last few hours my trackpad has been behaving terribly, jumping all over the place and sticking. I believe I remember there being an option to disable the trackpad when a mouse is plugged in in previous versions of OS X, but can't seem to find that option anymore.

Is such an option still available in Lion?

share|improve this question

2 Answers 2

up vote 9 down vote accepted

Thankfully, you can still disable the trackpad in OS X Lion.

Open System Preferences, click on Universal Access, select Mouse & Trackpad and click on Trackpad Options... at the bottom. Tick the checkbox "Ignore built-in trackpad when mouse or wireless trackpad is present".

Disable trackpad in OS X Lion

share|improve this answer

When you open up System Preferences, do not open up Trackpad or Mouse preferences as seen in the attached photo.

Look down in the lower right hand corner for the Universal Access preference and open that up to get to more features for both the trackpad and the mouse, including the 'permanent' solution to stuck/failed built-in trackpad or mouse issues ... see the 2nd picture of the Universal Access preferences, which include 'Ignore Built In Trackpad if Mouse is used...' option.

Now, you can practice not using your cheap or deprecated trackpad on your Mac Book ... and if you hit the trackpad or busted mouse click key on the trackpad by accident, it no longer will stop you or your mouse from working as if the trackpad no longer exists ... cheaper than fixing the cheap bastard !

UNIVERSAL ACCESS FROM SYSTEM PREFERENCES SCREEN SHOT 1 of 2

IGNORE BUILT IN TRACKPAD IF MOUSE USED OPTION IN UNIVERSAL ACCESS MENU 2 of 2

No, but there is an option labeled "Ignore accidental trackpad input" in System Preferences: Trackpad. Does that help?

share|improve this answer
    
Thanks, but unfortunately that didn't help. It's been getting worse, now it jerks the mouse to the left whenever I type in the left side of the keyboard. Nothing short of entirely disabling it is likely to help. –  Jeremy Banks Aug 11 '11 at 22:16
    
Try resetting the PRAM. What model Macintosh are you on, and how old is it? –  Wheat Williams Aug 12 '11 at 4:16
    
That worked! Thank you! It's a 15" MacBook Pro, exactly one year old. –  Jeremy Banks Aug 12 '11 at 4:24
    
Actually, the problem is coming back again as I leave the computer. Bah, glad I've got a warranty. –  Jeremy Banks Aug 12 '11 at 4:39
    
Well if you've got a warranty, take it right back to the Apple Store. It's likely a hardware problem. –  Wheat Williams Aug 12 '11 at 5:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.