Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've noticed since upgrading to Lion that doesn't seem to update the mailbox and synchronize properly with Exchange.

Before on SL, or using Outlook now, they always maintained correct state, matching with my iPhone, or webmail. Now, it seems that Lion gets lost. I have to force a sync, open and shut it, or change folders to get it to resync that folder contents.

Is this just me, or is this a known issue?

Is there a work around?


share|improve this question
Have you checked the activity and connection doctor windows to make sure it's not a temporary issue? – bmike Aug 9 '11 at 15:21
I can open up Activity then run a Get New Mail, and it will prompt a flurry of checking, but no change to the inbox. Restart will make it do a proper sync and it's fine. The mailbox isn't indicated as offline. – Alex Aug 9 '11 at 16:57
Yowsers - might be a bug, then. Connection doctor should show temporary server errors, but it seems you are having to hand tend this more than is warranted. – bmike Aug 9 '11 at 17:44
I noticed this for the first time today. I'm not sure if it is environment related or I have been in this location many times before without difficulty, so not sure. Did you ever find a solution/workaround? – minamhere Sep 21 '11 at 20:33
I have same issue. Check activity monitor and see if your Mail memory is creeping up over time. Mine would go to 3+GB. Lots of posts online with same issue but no solution so I went to Outlook. :/ – user15805 Jan 1 '12 at 10:14
up vote 1 down vote accepted

Try the rebuild utility through the app, I had a very similar problem and this resolved it for me. Best of luck.

share|improve this answer

1) Run the following in

sqlite3 ~/Library/Mail/V2/MailData/Envelope\ Index vacuum

2) And then select your Inbox, and select Mailbox->rebuild.

Worked for me :)

share|improve this answer
What exactly does this command (vacuum) do? – patrix Oct 14 '12 at 15:06

There is a partial work around for this:

Delete (or copy to somewhere else) this file: ~/Library/Preferences/

That stores your preferences for, after deleting it you will loose your preferences with the exception of your mail accounts.

This worked for me but a couple of months later the bug came back and I had to delete the file again.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.