Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

What is the best, easiest, preferably cheapest way to make OS X write to NTFS-formatted drives in Mac OS X?

share|improve this question
up vote 19 down vote accepted

Updated at May 2015, with current solutions.

Free solutions

FUSE for OS X - Successor to MacFUSE

Last updated 2010, pretty much abandoned in favour of the Paid version, Tuxera, unless you want to build from source. Last version linked from

Paid solutions

Paragon NTFS

Tuxera NTFS

MacFuse is abandonware, and hasn't been updated since 2009.

share|improve this answer
Fuse for OS X and NTFS-3G must be installed together. Full installation is tricky on El Capitan: See my answer – Cœur Oct 30 '15 at 23:26

I tested this on Mountain lion and it is free and you don't need to reboot. It uses OS X's native NTFS drivers.

  1. Plug-in your device

  2. Write in Terminal diskutil list and look for IDENTIFIER where TYPE is Windows_NTFS.

    In this case it is disk1s1

  3. Then run the following:

    diskutil unmount /dev/disk1s1
    cd /Volumes
    mkdir Elements
    sudo mount -w -t ntfs -o rw,nobrowse /dev/disk1s1 /Volumes/Elements
    open /Volumes/Elements
share|improve this answer
I tried this on 10.8.4 and a 10.8 VM, but I couldn't get it to work. I got an error like Read-only file system when I for example tried to run mkdir /Volumes/HD-HCU2/aa. Is there some reason why you used nobrowse? – user495470 Jul 27 '13 at 18:57
You are creating the folder on wrong path. You should create the folder under /Volumes. – Codler Jul 28 '13 at 7:28
nobrowse are needed to make ntfs writable. – Codler Jul 28 '13 at 7:32
+1, Be aware that this feature is not complete and well-tested. It's not enabled by default for some reason. Worth mentioning that the force-write-enabled driver simply damaged an NTFS volume while I was playing with it. – fardjad Oct 25 '13 at 21:52
So there is a capability within OS X to mount NTFS for read and write support. But this is disabled. Is there a way to do a 'defaults write' to activate this feature? – CousinCocaine Aug 5 '14 at 14:42

The simplest solution would be to use MacFUSE and NTFS-3G for MacFUSE, though as of this post only Tuxera NTFS ( ~$35 USD) and PARAGON Software NTFS for OS X v.9.0 ($19.95 USD) support 10.7. You can grab the source for free from Tuxera for free, however.

As of OS X 10.6 you can natively enable NTFS support, though your mileage may vary. Follow this writeup by Mac OS X Hints if you're interested but I'd use the MacFUSE method over this one. Keep in mind that neither of these methods are fully supported.

share|improve this answer
Just to note—I've had some problems with NTFS-3G & Lion lately, which might be because the OS X binary is a bit outdated (2010.10.2 versus 2011.4.12) – koiyu Aug 8 '11 at 17:08
Paragon NTFS for Mac v9 IS NOT COMPATIBLE WITH LION. Double-click the package gives "The operation couldn't be completed" – user17657 Jan 24 '12 at 3:42
any disadvantages of using Tuxera NTFS for the new macbook pro retina ? – Render Jul 23 '12 at 13:29
MacFUSE got replaced by FUSE for OS X – Cœur Oct 29 '15 at 16:03

Can't say that using MacFUSE and NTFS-3G for MacFUSE is the easiest way, but they are free and that's great!:) I've used them for about a year until bought 500GB external Seagate HDD and got Paragon NTFS for Mac driver for free from Seagate site: Works stable for a month, no problems happened yet. Anybody knows, will users of Seagate HDDs get free NTFS driver upgrade for new OS X when Apple will release it?

share|improve this answer
does the seagate version of paragon 14 work for drives other than seagate? – malhal Dec 30 '15 at 15:45

Before we start. Make sure your external name label is ONE word. That means there is no space in between.

my disk = WRONG

my_disk or my-disk or mydisk = CORRECT


  1. Open Terminal [Command+Space+"terminal"]
  2. Type: sudo nano /etc/fstab
  3. In nano, type: LABEL=my_disk none ntfs rw,auto,nobrowse Note: my_disk is your disk name
  4. To save and exit Control+X and Enter and Enter
  5. [optional] For ease of access, we create a sym-link to desktop: In terminal -> sudo ln -s /Volumes ~/Desktop/Volumes


When you don't need it anymore. It is as simple as:

In terminal sudo rm /etc/fstab

share|improve this answer
Removing /etc/fstab is only an option if it doesn't contain any other important entries – patrix Jul 11 '14 at 5:03
@AFwcxx, The Label can contain spaces, you just have to substitute \040 for the ' ' (space). See example in man fstab: LABEL=The\040Volume\040Name\040Is\040This none msdos ro – user3439894 Nov 10 '15 at 15:03

This answer is aimed at latest compatibility for OS X 10.11 El Capitan.

  1. Install latest osxfuse (3.x.x) from

  2. Install latest NTFS-3G (2015.3.14) from Homebrew (

As follow:

brew install homebrew/fuse/ntfs-3g
  1. Link NTFS-3G to boot after temporary disabling System Integrity Protection.

As follow:

[reboot by holding CMD+R to get in recovery mode]
csrutil disable
[reboot normally]
sudo mv /sbin/mount_ntfs /sbin/mount_ntfs.original
sudo ln -s /usr/local/sbin/mount_ntfs /sbin/mount_ntfs
[reboot by holding CMD+R to get in recovery mode]
csrutil enable
[reboot normally]
share|improve this answer
Ok, After doing all this will the NTFS vol automatically be mounted? – Mohammed Fawzan Dec 23 '15 at 6:30
@MohammedFawzan Yes, that's the goal. – Cœur Dec 23 '15 at 13:56
I tried all the steps. still I cannot write to the volumes. :/ – Mohammed Fawzan Dec 23 '15 at 13:57
Be sure that the brew install homebrew/fuse/ntfs-3g was successfull (read carefully). Also if you had previous versions of osxfuse or ntfs-3G, you need to uninstall them. – Cœur Dec 23 '15 at 14:00
I tried to re run the command I got the following message. omebrew/fuse/ntfs-3g-2015.3.14 already installed, it's just not linked – Mohammed Fawzan Dec 23 '15 at 14:01

protected by Community Mar 10 at 10:34

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.