Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm using Firefox, where CMD + ALT + ← / → Arrow changes to the next / previous tab. This is an important feature to me.

Since Lion, this shortcut changes the active space to the next and previous space, with no way to customize this. And I want to use spaces, just no with the keybinding. Firefox also won't let me customize my shortcut. How can I change one of those?

(Hint: the Firefox extension "keyconfig" let's you do a lot of keybindings-changes, but not the previous and next tab ones).

share|improve this question

2 Answers 2

up vote 0 down vote accepted

Ctrl-Tab and Shift-Control-Tab will have the same effect as CMD-ALT-← / →, and have the advantage of working in Safari, Firefox, and Chrome.

It's also nice to rebind them to function or gamepad keys so you can browse without contorting your hand à la emacs.

share|improve this answer

You can change Mission Control's keyboard shorcut from System Preferences/Keyboard/Keyboard Shourtcuts window or bind specific shortcut key for Firefox in same window.

share|improve this answer
    
Sorry, but I tried System Preferences/Keyboard/Keyboard Shourtcuts of course. Those are additional shortcuts you can set, but that doesn't remove CMD + ALT +Left/Right. The other shortlink you provided leads to an empty side and doesn't tell me where I can set the shortcuts in Firefox. –  Akku Aug 8 '11 at 9:28
1  
Plus, you can uncheck Mission Control keyboard shortcuts if you don't use it. By the way, i have Lion too but when i use CMD+ALT+Left/Right shortcut on Firefox (Also Chrome) it doesn't change the space. It's changing tabs normally. –  fatihturan Aug 8 '11 at 9:37
    
Ah, then maybe I configured something strangely that causes my spaces to get changed. This question therefore may just be stupid. Maybe BetterTouchTool or Keyboard Maestro or FunctionFlip have done something wrong here. Thank you! –  Akku Aug 8 '11 at 12:46
    
Found it: It was the "Switch to Next / Last Application" shortcut that's a default in Keyboard Maestro, that sits on those keys. It switched to an app in another space and did this before Firefox could get the keystroke. –  Akku Aug 8 '11 at 12:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.