Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have MacBook Air with Lion which has problems to join WIFI network which password is 7 chars long. Basically button is grayed out until i add more chars. Is there a way to force Lion to ignore this behavior or the only way to go thru is to change WIFI password? It's not my network so it's not so easy.

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

I assume you are being prompted for a WPA password. My SnowLeopard system (10.6.8) requires at least eight characters before enabling the OK button when I try to join a network using WPA. The Wikipedia page for Pre-shared key (PSK) indicates that the valid password length is between 8 and 63 characters.

I also tried joining an example wireless network configured with WEP, an older wireless security method. After entering just one character for the password, the OK button was enabled.

So, assuming you were given the correct password for the wireless network, it sounds like your computer believes that the wireless network uses WPA security when it actually uses WEP. There's no way that I see to change the security protocol for the wireless network from the password dialog; your computer automatically detects the security protocol and sets the minimum password length accordingly.

Are you sure you are trying to join the correct network? Does the password dialog specify WEP or WPA? Do you know another person who is successfully joining the network, and can you have them disconnect and reconnect to the network, entering the same password?

share|improve this answer
    
It was saying it's connecting to WPA but I'm not sure whether it's WPA, WEP or WPA2 now. I'll test it again when I get there. And yes, other 2 Windows computers were connected and working. –  MadBoy Aug 7 '11 at 20:13
    
I just checked the other computer and it seems to have different password that I tried to use. So I must have made mistake in typing the password as it wasn't accepting the password and so i tried different one. Thanks for pointing me out that it's between 8 and 63 chars length. –  MadBoy Aug 7 '11 at 20:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.