Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When I hold a key in Lion, I get this iOS-style character picker instead of a repeated character, as in previous versions of the OS:

screenshot

I really dislike this (I rarely use those symbols as I only speak Dutch and English). I want to hooooooooooold a key. :)

Where can I turn this off? I can't find an option in the system preferences.

share|improve this question

3 Answers 3

up vote 1 down vote accepted

You can do it with Terminal:

http://m10lmac.blogspot.com/2011/07/os-x-107-lion-getting-rid-of-character.html

share|improve this answer
1  
Logging off and on was enough (no complete reboot necessary). Apple should really add an option for this in the keyboard preferences. –  rightfold Aug 7 '11 at 11:00
1  
Agreed. Let Apple know via apple.com/feedback/macosx.html –  Tom Gewecke Aug 7 '11 at 13:10
    
For this kind of really short answers it is better to place the code snippet right here in answer along with the link. That way if the linked site goes down the snippet is still useful. –  LopSae Jan 10 at 23:33

You have to open a Terminal window and type in the following:

defaults write -g ApplePressAndHoldEnabled -bool false

(from this article)

share|improve this answer

If you’re interested in more of these "secret preferences" check out the awesome Secrets website. Better yet, consider installing Secrets’ accompanying prefpane which will allow you to update any of these through a GUI and auto-populates from Secrets‘ authoritative database of these little nuggets.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.