Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Once I upgraded to Lion, I found out that the vertical scrollbar is always plastered to the right side of the application window.

Because I run GNU Screen within Terminal.app, the right side of the screen session gets hidden partially underneath said scrollbar. Likewise for emacs sessions.

Is there a way to disable scrollbars in Terminal.app in Lion?

share|improve this question
add comment

3 Answers

up vote 10 down vote accepted

I assume you're not using a trackpad, and/or your Show scroll bars preference in System Preferences → General is set to either Automatically based on input device or Always (otherwise, you shouldn't be seeing persistent scrollbars).

Try changing this setting for Terminal only:

defaults write com.apple.Terminal AppleShowScrollbars WhenScrolling
share|improve this answer
    
I am using a trackpad, but the setting worked perfectly. Cheers! –  Alex Reynolds Aug 7 '11 at 11:02
    
This didn't work for me in OS X 10.8.5, but LionScrollbars did. –  Vebjorn Ljosa Oct 10 '13 at 12:50
add comment

Try LionScrollbars. It's the only thing that worked for me (besides setting the entire system to "When scrolling"). Works like a charm under 10.8.2.

share|improve this answer
add comment

System Preferences > General > Show scroll bars > When scrolling

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.