Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm using a Windows-type Logitech keyboard with my OS X 10.6.8 iMac. I've always just used the "Modifier Keys" setting in the Keyboard pane of System Preferences to reverse the Option and Command keys in order to get the usual Mac key behavior. Recently, however, it seems that these preferences are being ignored. I created a second account for my wife, and even though I swapped the modifier keys in the prefs dialog, the setting is ignored and Windows-style behavior continues. The same setting worked on my account but were ignored on hers (though they stayed as set, as if they were being honored).

More mysteriously, I undid those settings on my account while mucking around with a different peripheral, and now when I try to go back to swapped command and option keys, the setting is ignored on my account too! It seems that "inherited" pre-10.6.8 settings are honored, but that one can't swap those keys using 10.6.8 and have the system pay any attention.

Is there some duplicate preference file somewhere I should trash? Any other thoughts?

share|improve this question
    
At the top of the Modifier Keys preferences, is there a drop down menu? If so, are there multiple keyboards in that menu? –  Nathan Aug 6 '11 at 18:47
    
Yes, but there's only one keyboard listed: "USB Receiver". –  Ian Aug 9 '11 at 2:05
    
Additional information: I've got USB Overdrive installed, to configure some fancy extra buttons on my mouse. –  Ian Aug 9 '11 at 2:16
add comment

2 Answers 2

Okay I fixed it. New keyboard (still Windows-style, needing modifier key remapping), uninstalled USB overdrive, moved keyboard from external self-powered USB hub to port in back of second monitor, then back to hub. Modifier key remapping started being obeyed once I'd switched the keyboard to the monitor's USB port, and kept working when I switched back. Go figure!

share|improve this answer
add comment

Most likely cause is a mouse driver running in the background that's preventing the settings from saving. Do you or did you previously have a Logitech or Microsoft mouse? Try this:

  1. Shutdown your computer and unplug your mouse.
  2. Start your computer, with only the keyboard plugged in.
  3. After the startup process is finished, plug in the mouse and make the changes to the modifier key system preferences.

That should fix it.

share|improve this answer
    
Alas, no luck. I have a Logitech wireless mouse, and unplugging its receiver before booting didn't make any difference. (My keyboard is also a Logitech, and it came with a mouse ["cordless duo"], but I don't use that mouse because the acceleration curve stinks. I wonder, however, whether its driver automatically gets loaded anyway, since the receiver for the keyboard is the same as the receiver for the long-gone mouse...) –  Ian Aug 9 '11 at 2:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.