Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

On a MacBook5,2 running OSX 10.5, with only 2GB RAM, Alfred toggles very slowly, like up to 5 seconds after the keystroke. After I've just toggled it, it will toggle again much faster, but after a while it will be slow again. What can I do to identify and fix the problem?

IIRC it does that even with the computer just started, so it's unlikely it's already swapping, but I'm open to suggestions.

share|improve this question
add comment

2 Answers 2

up vote 7 down vote accepted

I'd recommend turning off fade-in animation under Appearance where you'll see "Fade in Alfred window".

The only reasons Alfred would be slow are either RAM swapping and you're out of memory or, unlikely but possible, could be due to a network drive that is still being looked for after being disconnected.

share|improve this answer
2  
Just for everyone's information, Vero is from the Alfred team, so I'd say she knows what she's talking about :) –  Loïc Wolff Aug 3 '11 at 19:01
    
Disabling the fade-in helped a lot. Now it still takes a few odd moments to load (on my other Mac it's instant), but since it's <1s I don't mind. Thanks :) –  Lohoris Aug 5 '11 at 7:40
add comment

Look on the features pane of the Alfred preference window. Untick any unnecessary options. That should speed Alfred up.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.