Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

And when I assign other command to left shift it display error, and when I press the sign it redirect me to the keyboard shortcut, which does not display any conflict...

I just want to use my right shift ToT

share|improve this question
add comment

1 Answer

I just had the same issue! I am using an external keyboard, btw, but I believe this fix should be the same.

First I just went ahead and restarted, then after my right shift was still acting wonky, I went into the Keyboard Shortcuts preferences, and changed the shortcut to numpad0. I saved it and did a restart again, then it was fixed.

enter image description here

I'm not sure if using the numpad altered the issue, or if all it took was multiple restarts, but before that, even if I disabled "Show Desktop" it would still be active as my Right Shift.

On a weird note, my show desktop used to be a 3 finger swipe down on the trackpad, but now that option isn't even available for me to select. Odd.

share|improve this answer
    
This happened to me too. –  Nathan Grigg Aug 3 '11 at 23:40
    
All the gestures changed in Lion. Bit annoying. It's now "spread your fingers" to show desktop. You can also set it to a hot-corner. I know this doesn't answer your question, hope this helps! –  Paul Eccles Aug 4 '11 at 6:56
    
Upon removing my external keyboard, my right shift went back to showing application windows. I realized that I had to go into "Keyboard Shortcuts" uncheck the application windows shortcut mode, go back into "Mission Control" and once I had deactivated the property in Keyboards, the Mission Control shortcut for the same feature said the shortcut was "Right Shift" (when originally, before I had unchecked the property in Keyboard, it had said Num0.) Basically, it seems that between "Mission Control" and "Kyboard Shortcuts" there are duplicate settings that DO NOT mirror each other. –  Alan Vitek Aug 9 '11 at 22:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.