Sign up ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When I click a Youtube link, say, in the newly released Skype app, the iPad will open the link in Safari, which will load the mobile site. Also in Twitter's built in browser the mobile site is displayed. This sucks, because the site is slow and often fails loading a video at all.

Is there a way to stop Youtube redirecting to on iPad?

share|improve this question

4 Answers 4

up vote 2 down vote accepted

In short: no, you can't stop it. It's Google re-directing you.

You can work around it though. You can scroll down to the very bottom of the page and tap the "desktop" link, which will take you to the full desktop version of the site. If what you want is the YouTube app to open, then all you can do is copy the name of the video from safari into the YouTube app.

I know what you mean about it not loading the videos. It's annoying!

share|improve this answer

Mobile seems to work better for me on my iPad, yet they keep redirecting me to the desktop version. I clicked it once to check messages because apparently you can't do that on mobile anymore.

They seriously discriminate against non desktop users. We can't watch half the videos because of restrictions. We can't even check messages now the app is dreadful it randomly changes quality of video to the lowest possible definition in the middle of a video. It seriously puts me off! My advice for you, however, tell YouTube you want it to redirect you to mobile version. 99.9% of the time they do the opposite to what you ask, so it should work!

share|improve this answer

Go to Settings, tap on General, tap on Restrictions, enable Restrictions if you haven’t already, and disallow YouTube.

Doing so has the dual benefit of redirecting all YouTube links to the mobile website and hiding the native app on the device, clearing up more space for apps you actually want to use.

share|improve this answer

Try YouTube link on chrome instead of safari also enable open links in chrome setting in YouTube app of iPad.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.