Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a new MacBook Pro 15" early 2011 and use Lion.

  1. For "Launchpad" I can't use the Shortcut F1.
  2. For "Move focus to menu bar" I can't use the Shortcut Cmd+Esc (+).

Simply said, there are functions, which are not working with one specific Shortcut. I can assign it, but it does not work.

The Shortcuts works for all the other functions and the one function works with all the other Shortcuts.

Sometimes when I wildly clicked around and restarted, the shortcut Cmd+Esc (+) worked with "Move focus to menu bar" one time.

What could I do to fix the bug?

share|improve this question
    
I can replicate this bug with my iMac mid-2010. It works when set to ctrl+esc (or any other shortcut), but not cmd+esc. I can use cmd+esc for any other function, but not for this one. –  Magnakai Aug 3 '11 at 11:25
    
There are some bugs where the menu bar doesn't get shortcuts when an app is in full screen. Are your troubles happening when the display isn't in full screen mode? –  bmike Aug 9 '11 at 21:10
    
The problem occurs in full screen as well as in normal window mode. The weird thing is: The Shortcut cmd+esc (⌘+⎋) works for the menu bar, IF I activated the menu bar with the Shortcut for MOVE FOCUS TO STATUS MENUS (also here the same in full screen or window mode) right before and a menu icon on the right side of the menu bar is highlighted –  user8551 Aug 10 '11 at 11:23
    
I've also encountered problems with assigning ⌘+⎋ as a shortcut or as a hotkey within an application in Lion. –  Daniel Lawson Sep 2 '11 at 0:55

3 Answers 3

Go to System Preferences -> Keyboard -> Keyboard Shortcuts -> and assign and enable the shortcuts you want.

share|improve this answer
    
Your answer works for many shortcuts, but there's something strange about ⌘+⎋ in Lion. –  Daniel Lawson Sep 2 '11 at 0:56
    
Yes. ⌘+⎋ doesn't work with all functions correctly. –  user8551 Sep 4 '11 at 9:31

I've realized that the ctrl-Fn shortcuts only work if I tick the option to use the function keys as "normal function keys". This option is in Systems Preferences > Keyboard > Keyboard. I believe it is unticked by default (ie the Fn keys work as shortcuts for brightness, sound level, and music playing). Once ticked, Ctrl-F2 works like a charm. Alternatively, you can leave this option unchecked and instead hit CTRL+fn+F2 and the intended function will work fine.

share|improve this answer
    
Yes but F1 is F1 not the "lesser brightness" key. So I used F1, when the same key reduces your brightness then you have to hold down the fn key. The problem didn't go away ;( –  user8551 Jul 31 '12 at 9:31
up vote 0 down vote accepted

With mountain lion the bug seems to be fixed. Now I have no problem assigning the hotkeys as desired.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.