Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I recently jailbroke my iPhone 3gs with jailbreakme.

At the beginning everything was working well. But since yesterday I am having problems with the network. It would disconnect from wifi and there is no way that I can reconnect until I reboot my phone. It happened twice so far, but I am not able to reproduce the problem as it doesn't happen all the time.

Anyone here has any hint on what I should check?


Edit: I found out that this problem occurs if it changes wifi network.

Edit: Resetting the network settings was the right solution for me. Does anyone know if this is a common problem? ( I was not able to find anything with google )

share|improve this question

2 Answers 2

That happened to me too, and now my wifi doesn't work anymore so you should expect that. (not much an answer just a comment)

3 possible fixes you can try: (they did not work for me)

1) Reset network settings: Settings -> General -> Reset -> Reset Network Settings.
3) When connected to your network click more info (the little > icon) and check if DHCP is enabled.
2) The last thing Restore your device from Itunes or reset the device from Settings -> General -> Reset -> Reset All Settings.

share|improve this answer
    
Thanks for your reply. I started to notice that it happened to me when I change wifi network. Is it the case also for you? –  Mr Woody Aug 16 '10 at 10:00
    
@Vlad answers are expected to help resolve the question. If you get 50 reputation you'll be able to comment directly. If you have any other Stack Exchange accounts with 200+ reputation you'll get 100 on this site for associating them. I'm going to delete this answer. If you have a solution to the problem feel free to edit your answer and flag it for moderator attention so it can be undeleted. –  Rich Seller Aug 16 '10 at 10:14
    
something strange happened on this website: I was only able to see only half the comment and this is the reason why I replied that way. Solution 1) worked so far. Hopefully the problem will not appear again. –  Mr Woody Aug 16 '10 at 13:38
    
yes this is a really common problem too bad it wont work for me too :( –  Vlad Patrascu Aug 16 '10 at 17:38

Have you tried resetting your network settings?

Here's how to do it:

Settings >> General >> Reset >> Reset Network Settings.

That usually solves network problems. If it doesn't work for you, please post back here and I'll try to help some more.

share|improve this answer
    
yes, thanks... this solution worked for me Do you know what exactly happen during network reset? –  Mr Woody Aug 16 '10 at 13:39
    
Cool. Glad it worked. It resets all network connections (WiFi, 3G/ EDGE, Bluetooth). Clears stored networks, passwords, etc, so when the phone reboots, all communications have to be renegotiated. I tried to find a decent article on support.apple.com, but this was all I could find: "When you reset network settings, your list of previously used networks and VPN settings not installed by a configuration profile are removed. Wi-Fi is turned off and then back on, disconnecting you from any network you’re on. The Wi-Fi and “Ask to Join Networks” settings are left turned on." bit.ly/ckuMb8 –  Thomas Aug 16 '10 at 14:23
    
Thanks again. I wonder why this tricks solves the problem that I had, since I tried to reboot but it was not enough. Probably it is related with the permission of some special files. –  Mr Woody Aug 16 '10 at 14:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.