Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When I'm writing text in Danish, the iPhone always auto-corrects foto into FOTO which is immensely annoying. How can I prevent that specific suggestion from ever showing up again?
This is iOS version 4.2.1.

First I thought that it was matching it with an entry in my address book, but there is no contact with "FOTO" in any of the name fields. I'm using several languages, and the bad replacement only shows in Danish and not in German and not in English. I haven't tested other languages.

Because my PC with iTunes is not working well, I'd appreciate suggestions different from "try upgrading iOS it might help" unless that is a proven fix. I don't want to have to upgrade the phone unless really, really necessary.

Update:

  1. As noted in an answer's comment, I don't want to turn off the autocorrect -- I just want it to work right. Thanks.
  2. Resetting the keyboard dictionary didn't help.
share|improve this question
1  
If you hold on long enough until iOS 5, there's a fix for this (was in WWDC, user dictionary). –  Enrico Susatyo Aug 1 '11 at 10:58

5 Answers 5

up vote 6 down vote accepted

Go into the keyboard settings and add a shortcut for the corrected spelling of the word. I had to do this with my daughter's name, as every time I spelled it, it would come out in capitals. You can just use a part of the word and it can auto spell the word for you, or you can spell it with a different capitalization and save the corrected version the other way.

If you need to use the first part of the word it may not work. Don't really know, but it worked for me ;-)

share|improve this answer
    
Is that new in iOS 5? I haven't seen that in my 4.x version. –  Torben Gundtofte-Bruun Dec 6 '11 at 7:50
    
Yes, it's a new feature in iOS 5. And I just checked it with the danish keyboard and it works. –  Turismo Dec 6 '11 at 10:25
    
I can confirm that this does exactly what I need - perfect! –  Torben Gundtofte-Bruun May 3 '12 at 18:05

iPhone seems to remember your choice when you dismiss an autocorrection in Safari. If that doesn't work for you, you can always take the nuclear option and disable autocorrection altogether: Settings -> General -> Keyboard -> Auto-Correction (eller Indstillinger -> Generelt -> Tastatur -> Automatisk rettelse hvis du benytter dansk på din iPhone)

share|improve this answer
    
You're right that iPhone usually remembers and learns from my word choices, and that generally works well on my phone (+1 for that) so I don't want to turn it off entirely. That's like tearing down a house because a floorboard is squeaking (-1 for that). –  Torben Gundtofte-Bruun Aug 1 '11 at 9:56

You can try reseting the keyboard dictionary by going to:

Settings –> General –> Reset –> Reset Keyboard Dictionary

Warning before you try this - this will erase all of the auto correct entries you have added to the dictionary since you got the phone. But I've had success in doing this when it kept auto correcting as to a's.

share|improve this answer
    
I'll try that. Losing the learned dictionary is not a big problem, it'll get the hang of it again. –  Torben Gundtofte-Bruun Aug 1 '11 at 11:04
    
Nope, that didn't solve the problem! –  Torben Gundtofte-Bruun Aug 1 '11 at 11:24
    
@torbeng - Well that is odd. Is FOTO an abbreviation for a company or something used in your country? –  chrisvick Aug 2 '11 at 1:49
    
As far as I know, there's no word or common name like that. It's just "photo" capitalized for some reason. Maybe Apple's way of pranking users. –  Torben Gundtofte-Bruun Aug 2 '11 at 5:51

I had the same problem that it always corrected a word 'support' to 'SUPPORT' I typed to capitals despite resetting my dictionary on multiple occasions.

I searched in spotlight for 'SUPPORT' and discovered that I had the word 'SUPPORT' as part of a contacts name. I corrected this to 'support' and then this reset the dictionary again for good measure and this fixed the problem completely.

share|improve this answer

Although this is a super-old question, I thought I'd add an update for what has worked for me in iOS8, as the autocorrect seems to have become 10 times more annoying: constantly changing Christmas to CHRISTMAS and my name (Lawrie) to - inexplicably - 'lAwrie'.

Open up Notes and type the word you want that autocorrect keeps screwing up (in my case, Christmas). As you're typing, it may suggest the correct spelling word on either side of the autocorrect suggestion, or have the 'literal' word you're typing in quotes. Select the one you want. Now do this about 3 times. You should find that, by the third or fourth time, it won't try to all-caps your word, or randomly throw capital letters in the middle of your name. After that, it should autocorrect the word correctly every time, and there's no need to wipe your dictionary.

Note: The inline autocorrect has changed in iOS8 and is now part of the autosuggestions bar, below the typing area. If you don't see it when you're typing, there should be a thin grey bar with a white line in the centre - flick that up and you'll see it. When it's going to autocorrect a word for you, it's highlighted in blue; otherwise it's just a suggestion.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.