Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

So I've upgraded to Lion, but now I can't enable File Sharing, when I press the checkbox, it simple shows the "correct" symbol and in less than half of a second it removes it again.

This happens the same for the 2 checkboxes under the Options... as well.

What can I do to enable File Sharing again?

enter image description here

enter image description here

share|improve this question
    
I'd check the Console application (it is in the Applications/Utilities folder) and see what happens when you check the box. You'll get the full readout there. Update your post with the console messages if you need more help. –  Nate Bird Aug 1 '11 at 1:16
add comment

1 Answer

It turns out it's not only me, but following this amazing tutorial everything whent smooth and worked out nicely...

enter image description here

share|improve this answer
    
Your answer seems to contradict itself. The article you link says to disable the built in sharing - yet you show it enabled in the picture in the answer. I can see using macports to compile your own smb sharing program might work, but either the article is partly wrong or you have some extra steps to get the ports smb connected to the sharing preference pane. Could you edit/elaborate on your solution so others can make use of it? –  bmike Sep 9 '11 at 14:06
    
it was only to let users know that it stays on, before, when you click it automatically unchecked no given us that ability, the article is correct, the image was only to let know, that it fixes :) –  balexandre Sep 10 '11 at 5:15
    
You're right - it was just me that was confused. You did mention it would click and then revert. Thanks for the clarification! –  bmike Sep 10 '11 at 13:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.