Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

A few months ago I setup an Instiki wiki using Snow Leopard. It took me quite a while, as I had to work some black magic to understand which version of ruby (plus gems/rails) I was supposed to install/update.

Now I've upgraded to Lion after formatting (bad idea huh?), and I'd like a new instiki up and running. So I thought: instead of wasting another day in trial and error I might ask if someone smarter and more knowledgeable has a quick and dirty way to do it (e.g. avoiding installing xcode tools!).


p.s. Instiki is very cool, especially if you like maths. Its user-friendliness is very far from Tiddlywiki, but I think it's much cooler.

p.p.s. please feel free to retag appropriately.

EDIT As pointed out, some more info might be useful. When I try to run instiki (contained in a folder named taccuino) this is what it tells me

./Desktop/taccuino/config/../config/preinitializer.rb:20: Bundler couldn't find some gems.Did you run `bundle install`? (RuntimeError)
from ./Desktop/taccuino/config/boot.rb:28:in `load'
from ./Desktop/taccuino/config/boot.rb:28:in `preinitialize'
from ./Desktop/taccuino/config/boot.rb:10:in `boot!'
from ./Desktop/taccuino/config/boot.rb:124
from ./Desktop/taccuino/script/server:3:in `require'
from ./Desktop/taccuino/script/server:3
from ./Desktop/taccuino/instiki:6:in `load'
from ./Desktop/taccuino/instiki:6
share|improve this question
It looks like there are binaries available for OS X, though they may be old. Have you tried installing as a gem? – jtbandes Jul 31 '11 at 18:42
I'll have a look. Perhaps I should say that if I try to run instiki the error I receive says "Bundler couldn't find some gems". – donkey kong Jul 31 '11 at 18:50
I tried but I don't have a 'gems' command and typing 'gem instiki' gives me an error (command instiki not found). So it looks like I still have to resort to downloading all possible combinations of rubies! – donkey kong Jul 31 '11 at 18:55
Try gem install instiki, perhaps? – jtbandes Jul 31 '11 at 19:03
nada :(, but thanks. – donkey kong Jul 31 '11 at 20:18

See here for proper instructions.

But, in brief,

ruby bundle
./instiki --daemon

I don't think there's anything quicker than that.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.