Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a MacBook Pro from mid 2009 annoying me.

When I turn it on, the led blinks rapidly, about 14 times, and then the Mac beeps once. The screen remains black and nothing happens. So I have to hold down the power button to force a shutdown. When I turn it on again, no beep or blinks, but still a black screen. I repeat that 3 more times and the Mac finally turns on and works normally. I use it, shut it down and when I want to use it again, I have to go through that process all over again: the beep, blinks and 4 tries until it comes back to life.

I've opened it and tried changing the memories, the hard drive, but no different results.

It's worth mentioning that I was reinstalling it for triple boot when that happened, however I've repartitioned the HD and it's back to the original state now, so I believe it does't have to do with that reinstall.

I'm not able to run the hardware test pressing D before startup, even with the original disc.

I googled for it but couldn't find any alike pattern.

Any ideas?

share|improve this question
    
Have you taken it to an Apple store? –  jtbandes Jul 31 '11 at 21:16

2 Answers 2

Have you recently changed your RAM configuration? If so, or even if not, try reseating your RAM. From this article:

If you turn on a MacBook when it’s completely powered off (not sleeping), and instead of starting up, the screen remains dark and the sleep light is blinking, the MacBook’s RAM might not be installed properly or might have worked loose.

I think you also see the rapidly-blinking light when doing a firmware update, but I think a RAM issue is more likely than a firmware-related issue. You can also check out this page for beep pattern definitions.

share|improve this answer
    
I haven't change the RAM configuration. I thought it could be the RAM, so I resat it, tried switching them, leaving just one, but no luck. I checked that page but the closest thing is one beep. But I couldn't find something about that rapid blink anywhere. Thanks! –  João de Araujo Jul 31 '11 at 21:14

Found the answer. The problem was due to the installation of rEFIt for the triple boot.

I found the detailed video solution here: http://www.youtube.com/watch?v=qPoU8838KDo

share|improve this answer
    
Please accept your answer. –  daviesgeek Nov 9 '11 at 18:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.