Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

In my recently acquired iPad2, the Safari "Open Page" button is not working. All the rest of the buttons work fine, except this one... The oddest thing is that when I "long-tap" a link and choose "Open in a new page", the animation shows all the other pages (though I can't tap/select/close any of them) before opening the new page...

Deleting the Safari cache/history works to get a new "blank" page but not to get the button working. I've tried closing Safari, powering off and even "rebooting" (home-sleep for 15 seconds) the iPad with the same result.

This was working fine before; I updated to 4.3.5 yesterday so I'm blaming it on that.

Any ideas? It's really a PITA not to basically be able to use Safari.

share|improve this question
    
You should upgrade to iOS 5, it's much better and you'll probably fix you're issue. –  Jonathan. Oct 27 '11 at 21:10
add comment

2 Answers

up vote 1 down vote accepted

Sorry for the delay in getting back: Unpdting to 5.0 didn't fix the issue, and I noticed the "dead spot" on other apps so, to I finally took the iPad to an apple store, where they diagnosed a problem with the screnn: there was a strip, around 1 cm wide that was not working properly. Got a new one and now I'm a happy camper!!

share|improve this answer
add comment

It seems your iPad update to iOS 4.3.5 was not completely successful.

You can try to backup your iPad, reinstall the update and put your backup back in place (there should be no data loss).

If it still doesn't work, try to reinstall your iPad without re-applying your backup. You will lose all your apps settings.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.