Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When parental controls are enabled and computer time setting is set, the controlled user will be shown a dialog 15, 5 and 1 minute(s) before the time is up:

"Your computer time is almost up." dialog

An admin user can add more computer time through this dialog (15 min, 30 min, rest of the day etc.), if he wishes.

Is there a way to disable this dialog? — no mercy!*

I know it's not available through the System Preferences, but is there some sort of hidden setting that can be reached through, e.g. Terminal? Or alternatively, is there a way to automatically send ⌘ + W key combo when a specific dialog appears?

I'm (still) on Snow Leopard, but if some answer would work on Lion, I'm willing to accept it.

*) Actually I've enabled parental controls for my sock–puppet account and, because I know the admin password, adding time through this dialog would be just too easy.**

**) I also know that, being an admin, I could add more time in many different ways and blocking this dialog wouldn't prevent me adding more time in other ways. But—like I said—adding time through this dialog is too easy.

share|improve this question
    
Is this dialog on your end or the users end? Where did you not want to see it? There's way to disable it, although it would require patching the ParentalControls.app –  l'L'l Sep 21 '11 at 20:05

2 Answers 2

Copy and paste this line into Terminal

sudo chmod 000 /System/Library/CoreServices/SecurityAgentPlugins/FamilyControls.bundle/Contents/Resources/English.lproj/localizable.strings

Note that should be allllll one line!

Then try again and see what happens.

[edit: Sorry! I should have explained this. 'chmod 000' means "no one can read, write, or execute this file, not even the owner of the system. You might have to restart to get the system to notice that you did this. In general, I do not recommend making any sorts of changes to anything in /System/, but you seemed to want "any solution"]

By the way, to reverse this, paste this line into Terminal

sudo chmod 644 /System/Library/CoreServices/SecurityAgentPlugins/FamilyControls.bundle/Contents/Resources/English.lproj/localizable.strings

[edit: chmod 644 says "the owner can read/write, users of the group that owns the file can read, and others can read also. Those are the default permissions for the file, according to my system.]

share|improve this answer
2  
It might be helpful to know what the terminal command does exactly, instead of waiting to see what happens. Could you please explain? Thanks! –  l'L'l Sep 23 '11 at 4:22
1  
I can tell you that the file at that path contains the text of that dialog box, and the command sudo chmod 000 will effectively prohibit any app from reading it. I guess the theory is that will cause the dialog to fail and it simply won't show up, but it's just as likely to show up blank, or crash, or anything at all. –  benzado Sep 23 '11 at 6:48
    
This didn't work — the dialog still popped up. –  l'L'l Sep 23 '11 at 15:46
    
If you did not restart the computer after making the change (chmod 000) try that. There should be no way for it to read that file (and therefore no way to present that dialog box, I would assume) if it can't read the strings… but I may be wrong. –  TJ Luoma Sep 23 '11 at 18:18
2  
+1 for creative answer, but most localization systems have defaults for when the locale files are missing. –  CajunLuke Sep 23 '11 at 18:56

/System/Library/CoreServices/SecurityAgentPlugins/FamilyControls.bundle/Contents/Resources/English.lproj/FamilyControls.nib is a binary xml file that can be opened by TextWrangler. This isn't a developed solution (yet), but I'd suggest some well-placed edits to this nib might be able to disable the dialog, perhaps by making buttons disappear. At any rate, this sounds more promising than randomly zeroing out portions of the binary using a hex-editor, which is the other channel I've been exploring.

share|improve this answer
    
Now all we need is a "nib-o-suction" expert - good find! –  bmike Sep 27 '11 at 17:34
    
I'm reluctant to hack system files on my own computer (because I kind of need it to work for, well, work), so as fascinating as I find this, I might be out soon -- unless I find another nib for a non-system file and practice hacking that to see what makes buttons disappear. –  Daniel Lawson Sep 27 '11 at 18:09
    
Sadly, XCode won't edit compiled nibs in the GUI, and converting it to a non-compiled xml file will open in XCode, but only as a plist, not in the interface builder. –  Daniel Lawson Sep 27 '11 at 18:11
    
If you're wanting this bad enough and willing to go to the extreme of editing the .nib you might as well just nop the call to the dialog in the app. This could easily be done by replacing 4 bytes in the binary; if someone really wants this 'non-feature' let me know and make patch for it. ;-) –  l'L'l Sep 28 '11 at 0:14
    
This comment thread is getting rather long. Anyone interested might want to join in chat at chat.stackexchange.com/rooms/1457/… –  Daniel Lawson Sep 28 '11 at 2:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.